]> git.pld-linux.org Git - packages/perl-Try-Tiny.git/blame - perl-Try-Tiny.spec
- updated to 0.30
[packages/perl-Try-Tiny.git] / perl-Try-Tiny.spec
CommitLineData
1b3c7fc1 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Try
7%define pnam Tiny
8Summary: Try::Tiny - minimal try/catch with proper localization of $@
9Summary(pl.UTF-8): Try::Tiny - minimaly try/catch z odpowiednią lokalizacją $@
10Name: perl-Try-Tiny
cde1e910 11Version: 0.30
f7e2ad20 12Release: 1
cde1e910 13License: MIT
1b3c7fc1 14Group: Development/Languages/Perl
734d46d9 15Source0: http://www.cpan.org/modules/by-authors/id/E/ET/ETHER/Try-Tiny-%{version}.tar.gz
cde1e910 16# Source0-md5: eb362c3cb32c42f9f28de9ddb7f2ead6
1b3c7fc1 17URL: http://search.cpan.org/dist/Try-Tiny/
0aca0ac8 18BuildRequires: perl-ExtUtils-MakeMaker >= 6.30
1b3c7fc1 19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25This module provides bare bones try/catch statements that are designed
26to minimize common mistakes with eval blocks, and NOTHING else.
27
28This is unlike TryCatch which provides a nice syntax and avoids adding
29another call stack layer, and supports calling return from the try
30block to return from the parent subroutine. These extra features come
31at a cost of a few dependencies, namely Devel::Declare and
32Scope::Upper which are occasionally problematic, and the additional
33catch filtering uses Moose type constraints which may not be desirable
34either.
35
36The main focus of this module is to provide simple and reliable error
37handling for those having a hard time installing TryCatch, but who
38still want to write correct eval blocks without 5 lines of boilerplate
39each time.
40
01905611
JB
41%description -l pl.UTF-8
42Ten moduł udostępnia proste instrukcje try/catch zaprojektowane w
43celu ograniczenia popularnych błędów w blokach eval - i NIC więcej,
44w przeciwieństwie do TryCatch, który udostępnia ładną składnię oraz
45zapobiega dodawaniu kolejnej warstwy stosu wywołań i obsługuje powrót
46z bloku try do procedury wywołującej. Te dodatkowe możliwości są
47okupione kilkoma zależnościami (Devel::Declare i Scope::Upper), które
48bywają problematyczne, a dodatkowe filtrowanie catch wykorzystuje
49ograniczenia typu Moose, które mogą być niepożądane.
1b3c7fc1 50
01905611
JB
51Głównym celem tego modułu jest udostępnienie prostej i wiarygodnej
52obsługi błędów dla zmęczonych instalowaniem TryCatch, ale nadal
53chcących pisać proste bloki eval bez każdorazowych 5 nadmiarowych
54linii.
1b3c7fc1 55
56%prep
57%setup -q -n %{pdir}-%{pnam}-%{version}
58
59%build
60%{__perl} Makefile.PL \
61 INSTALLDIRS=vendor
62%{__make}
63
64%{?with_tests:%{__make} test}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69%{__make} pure_install \
70 DESTDIR=$RPM_BUILD_ROOT
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%files
76%defattr(644,root,root,755)
cde1e910 77%doc Changes LICENCE
6df5e55d 78%dir %{perl_vendorlib}/Try
01905611
JB
79%{perl_vendorlib}/Try/Tiny.pm
80%{_mandir}/man3/Try::Tiny.3pm*
This page took 0.068357 seconds and 4 git commands to generate.