]> git.pld-linux.org Git - packages/perl-Tree-Trie.git/blame - perl-Tree-Trie.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Tree-Trie.git] / perl-Tree-Trie.spec
CommitLineData
49af9da9 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
12b6d072 5%define pdir Tree
6%define pnam Trie
959770bc 7Summary: Tree::Trie - an implementation of the Trie data structure in Perl
5f6f5737 8Summary(pl.UTF-8): Tree::Trie - implementacja perlowa struktury danych Trie
fe4f5817 9Name: perl-Tree-Trie
f0254b04 10Version: 1.9
7a4e25ce 11Release: 1
49af9da9 12# same as perl
13License: GPL v1+ or Artistic
fe4f5817 14Group: Development/Languages/Perl
e5be7abf 15Source0: http://www.cpan.org/modules/by-module/Tree/%{pdir}-%{pnam}-%{version}.tar.gz
f0254b04 16# Source0-md5: 1b823d1896e43279227d65e6ff947d98
e5be7abf 17URL: http://search.cpan.org/dist/Tree-Trie/
225b1ef4 18BuildRequires: perl-devel >= 1:5.8.0
8a2d8bad 19BuildRequires: rpm-perlprov >= 4.1-13
d2d30fc0
MP
20%if %{with tests}
21BuildRequires: perl-Test-Pod-Coverage
22%endif
e5d9bc5a 23BuildArch: noarch
550d67c8 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
fe4f5817 25
26%description
c2c4c98d
JB
27This module implements a trie data structure. The term "trie" comes
28from the word re*trie*val, but is generally pronounced like "try". A
29trie is a tree structure (or directed acyclic graph), the nodes of
30which represent letters in a word. For example, the final lookup for
31the word 'bob' would look something like
32$ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (the HASH being an end
33marker). Only nodes which would represent words in the trie exist,
34making the structure slightly smaller than a hash of the same data
35set.
36
99b97fd0
JR
37%description -l pl.UTF-8
38Ten moduł jest implementacją struktury danych Trie. Termin "trie"
39pochodzi od słowa "re*trie*val" (odtwarzanie, odzyskiwanie), ale
40jest wymawiany jak angielskie słowo "try". Trie to struktura
41drzewiasta (lub skierowany graf acykliczny), której węzły reprezentują
42litery w słowie. Na przykład, końcowe wyszukiwanie słowa "bob" będzie
43wyglądać podobnie do $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (gdzie
44HASH jest znacznikiem końca). W strukturze istnieją tylko węzły
45reprezentujące słowa, co czyni strukturę mniejszą niż hasz z tego
c2c4c98d 46samego zbioru danych.
fe4f5817 47
48%prep
4eef7744 49%setup -q -n %{pdir}-%{pnam}-%{version}
fe4f5817 50
51%build
8a2d8bad 52%{__perl} Makefile.PL \
76f35363 53 INSTALLDIRS=vendor
d4c857aa 54%{__make}
fe4f5817 55
49af9da9 56%{?with_tests:%{__make} test}
57
fe4f5817 58%install
59rm -rf $RPM_BUILD_ROOT
fe4f5817 60
49af9da9 61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
fe4f5817 63
fe4f5817 64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
16931d4f 69%doc Changes README
8a2d8bad 70%{perl_vendorlib}/Tree/Trie.pm
fe4f5817 71%{_mandir}/man3/*
This page took 0.655822 seconds and 4 git commands to generate.