]> git.pld-linux.org Git - packages/perl-Throwable.git/blame_incremental - perl-Throwable.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Throwable.git] / perl-Throwable.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Throwable
6Summary: Throwable - a role for classes that can be thrown
7Name: perl-Throwable
8Version: 0.200013
9Release: 1
10# same as perl
11License: GPL v1+ or Artistic
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/Throwable-%{version}.tar.gz
14# Source0-md5: 92d4934f601c2d291a65b0bf2ab08dd3
15URL: https://github.com/rjbs/Throwable
16BuildRequires: perl-devel >= 1:5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18%if %{with tests}
19BuildRequires: perl-Class-Method-Modifiers
20BuildRequires: perl-Devel-StackTrace >= 1.32
21BuildRequires: perl-Module-Runtime >= 0.002
22BuildRequires: perl-Moo
23%endif
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Throwable is a role for classes that are meant to be thrown as
29exceptions to standard program flow. It is very simple and does only
30two things: saves any previous value for $@ and calls die $self.
31
32Throwable is implemented with Moo, so you can stick to Moo or use
33Moose, as you prefer.
34
35%prep
36%setup -q -n %{pdir}-%{version}
37
38%build
39%{__perl} Makefile.PL \
40 INSTALLDIRS=vendor
41%{__make}
42
43%{?with_tests:%{__make} test}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47%{__make} pure_install \
48 DESTDIR=$RPM_BUILD_ROOT
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc Changes README
56%{perl_vendorlib}/*.pm
57%{perl_vendorlib}/StackTrace
58%{perl_vendorlib}/Throwable
59%{_mandir}/man3/*
This page took 0.548904 seconds and 4 git commands to generate.