]> git.pld-linux.org Git - packages/perl-Test-UseAllModules.git/blame - perl-Test-UseAllModules.spec
use generic url
[packages/perl-Test-UseAllModules.git] / perl-Test-UseAllModules.spec
CommitLineData
748e0156 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
9fb9b76b 4
748e0156 5%define pdir Test
6%define pnam UseAllModules
9fb9b76b 7%include /usr/lib/rpm/macros.perl
748e0156 8Summary: Test::UseAllModules - do use_ok() for all the MANIFESTed modules
9Summary(pl.UTF-8): Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
10Name: perl-Test-UseAllModules
da9ac185 11Version: 0.13
748e0156 12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
da9ac185 17# Source0-md5: b591f8f8de76dd36422a60e2d02fcbdd
9fb9b76b 18URL: http://search.cpan.org/dist/Test-UseAllModules/
748e0156 19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
748e0156 21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
da9ac185 25I'm sick of writing 00_load.t (or something like that) that'll do
26use_ok() for every module I write. I'm sicker of updating 00_load.t
27when I add another file to the distro. This module reads MANIFEST to
28find modules to be tested and does use_ok() for each of them. Now all
29you have to do is update MANIFEST. You don't have to modify the test
30any more (hopefully).
748e0156 31
32%description -l pl.UTF-8
33Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
34
35%prep
36%setup -q -n %{pdir}-%{pnam}-%{version}
37
38%build
39%{__perl} Makefile.PL \
40 INSTALLDIRS=vendor
41%{__make}
42
43%{?with_tests:%{__make} test}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47
48%{__make} install \
49 DESTDIR=$RPM_BUILD_ROOT
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(644,root,root,755)
56%doc Changes README
57%{perl_vendorlib}/Test/*.pm
58%{_mandir}/man3/*
This page took 0.054469 seconds and 4 git commands to generate.