]> git.pld-linux.org Git - packages/perl-Test-Requires.git/blame - perl-Test-Requires.spec
- macros for perl autodeps
[packages/perl-Test-Requires.git] / perl-Test-Requires.spec
CommitLineData
9dcb70c5
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Test
6%define pnam Requires
9dcb70c5
JB
7Summary: Test::Requires - checks to see if the module can be loaded
8Summary(pl.UTF-8): Test::Requires - sprawdzanie, czy moduł może być załadowany
9Name: perl-Test-Requires
e1dfe4fb 10Version: 0.10
9dcb70c5
JB
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
e1dfe4fb
JB
15Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 0d5da779609d0c8fa6f796b45ff8c6f3
d28f7091 17URL: https://metacpan.org/release/Test-Requires
e1dfe4fb 18BuildRequires: perl-ExtUtils-MakeMaker >= 6.64
9dcb70c5
JB
19%{?with_tests:BuildRequires: perl-Test-Simple >= 0.61}
20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
d28f7091 22BuildRequires: rpmbuild(macros) >= 1.745
9dcb70c5
JB
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Test::Requires checks to see if the module can be loaded.
28
29If this fails rather than failing tests this skips all tests.
30
31%description -l pl.UTF-8
32Test::Requires sprawdza, czy moduł może być załadowany.
33
34Jeśli to nie powiedzie się, to zamiast niepowodzeń przy uruchamianiu
35testów pomijane są wszystkie testy.
36
37%prep
38%setup -q -n %{pdir}-%{pnam}-%{version}
39
40%build
41%{__perl} Makefile.PL \
42 INSTALLDIRS=vendor
43%{__make}
44
45%{?with_tests:%{__make} test}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50%{__make} pure_install \
51 DESTDIR=$RPM_BUILD_ROOT
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%doc Changes
59%{perl_vendorlib}/Test/Requires.pm
60%{_mandir}/man3/Test::Requires.3pm*
This page took 0.077596 seconds and 4 git commands to generate.