]> git.pld-linux.org Git - packages/perl-Test-Identity.git/blame - perl-Test-Identity.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Identity.git] / perl-Test-Identity.spec
CommitLineData
92ce0b57
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Test
6%define pnam Identity
92ce0b57
JB
7Summary: Test::Identity - assert the referential identity of a reference
8Summary(pl.UTF-8): Test::Identity - sprawdzenie identyczności referencji
9Name: perl-Test-Identity
10Version: 0.01
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Test/PEVANS/Test-Identity-%{version}.tar.gz
16# Source0-md5: ecef85c791cf5847e4c374983cf22a74
17URL: http://search.cpan.org/dist/Test-Identity/
18BuildRequires: perl-Module-Build
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-Test-Simple
23%endif
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28This module provides a single testing function, identical. It asserts
29that a given reference is as expected; that is, it either refers to
30the same object or is undef. It is similar to Test::More::is except
31that it uses refaddr, ensuring that it behaves correctly even if the
32references under test are objects that overload stringification or
33numification. It also provides better diagnostics if the test fails.
34
35%description -l pl.UTF-8
36Ten moduł udostępnia pojedynczą funkcję testującą: identical, służącą
37do upewnienia się, że podana referencja jest zgodna z oczekiwaniami,
38tzn. albo odnosi się do tego samego obiektu, albo jest równa undef.
39Jest podobna do Test::More::is, ale używa refaddr, więc działa
40poprawnie nawet jeśli testowane referencje są obiektami
41przeciążającymi konwersję na łańcuch lub liczbę. Moduł zapewnia także
42lepszą diagnostykę w przypadku niepowodzenia testu.
43
44%prep
45%setup -q -n %{pdir}-%{pnam}-%{version}
46
47%build
48%{__perl} Build.PL \
49 destdir=$RPM_BUILD_ROOT \
50 installdirs=vendor
51./Build
52
53%{?with_tests:./Build test}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58./Build install
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(644,root,root,755)
65%doc Changes README
66%{perl_vendorlib}/Test/Identity.pm
67%{_mandir}/man3/Test::Identity.3pm*
This page took 0.153257 seconds and 4 git commands to generate.