]> git.pld-linux.org Git - packages/perl-Taint-Util.git/blame - perl-Taint-Util.spec
rebuild with perl 5.32
[packages/perl-Taint-Util.git] / perl-Taint-Util.spec
CommitLineData
6e8287cc
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Taint
6%define pnam Util
6e8287cc
JB
7Summary: Taint::Util - Test for and flip the taint flag without regex matches or eval
8Summary(pl.UTF-8): Taint::Util - sprawdzanie i zmiana flagi skażenia bez wyrażeń regularnych ani eval
9Name: perl-Taint-Util
10Version: 0.08
c800ea17 11Release: 8
6e8287cc
JB
12# same as perl 5
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Taint/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 4f081a8a6e82352741c0486784cbc23d
17URL: http://search.cpan.org/dist/Taint-Util/
18BuildRequires: perl-ExtUtils-MakeMaker >= 6.11
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-Test-Simple
23%endif
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Taint::Util wraps Perl's internal routines for checking and setting
28the taint flag and thus does not rely on regular expressions for
29untainting or odd tricks involving eval and kill for checking whether
30data is tainted, instead it checks and flips a flag on the scalar
31in-place.
32
33%description -l pl.UTF-8
34Taint::Util obudowuje wewnętrzne procedury Perla do sprawdzania i
35ustawiania flagi skażenia, dzięki czemu nie polega na wyrażeniach
36regularnych w celu usuwania flagi lub brzydkich sztuczkach z eval i
37kill w celu sprawdzenia, czy dane są skażone - zamiast tego sprawdza
38i przełącza flagę zmiennych skalarnych w miejscu.
39
40%prep
41%setup -q -n %{pdir}-%{pnam}-%{version}
42
43%build
44%{__perl} Makefile.PL \
45 INSTALLDIRS=vendor
46%{__make} \
47 CC="%{__cc}" \
48 OPTIMIZE="%{rpmcflags}"
49
50%{?with_tests:%{__make} test}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} pure_install \
56 DESTDIR=$RPM_BUILD_ROOT
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc ChangeLog
64%dir %{perl_vendorarch}/Taint
65%{perl_vendorarch}/Taint/Util.pm
66%dir %{perl_vendorarch}/auto/Taint
67%dir %{perl_vendorarch}/auto/Taint/Util
68%attr(755,root,root) %{perl_vendorarch}/auto/Taint/Util/Util.so
69%{_mandir}/man3/Taint::Util.3pm*
This page took 0.166147 seconds and 4 git commands to generate.