]> git.pld-linux.org Git - packages/perl-Spreadsheet-Read.git/blame - perl-Spreadsheet-Read.spec
- fix perl paths
[packages/perl-Spreadsheet-Read.git] / perl-Spreadsheet-Read.spec
CommitLineData
c807ecde
JR
1# Conditional build:
2%bcond_without tests # do not perform "make test"
3#
4%define pdir Spreadsheet
5%define pnam Read
6%include /usr/lib/rpm/macros.perl
7Summary: Spreadsheet::Read - Read the data from a spreadsheet
8Name: perl-Spreadsheet-Read
9Version: 0.47
7abf5d48 10Release: 2
c807ecde
JR
11License: GPL v1+ or Artistic
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-module/Spreadsheet/%{pdir}-%{pnam}-%{version}.tgz
14# Source0-md5: 84fe60094d79a6e85c6ed414a77e89cb
15URL: http://search.cpan.org/~hmbrand/Spreadsheet-Read/
16BuildRequires: perl-devel >= 1:5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18%if %{with tests}
19BuildRequires: perl-Test-NoWarnings
20%endif
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Spreadsheet::Read tries to transparently read *any* spreadsheet and
26return its content in a universal manner independent of the parsing
27module that does the actual spreadsheet scanning.
28
29For OpenOffice this module uses Spreadsheet::ReadSXC
30
31For Microsoft Excel this module uses Spreadsheet::ParseExcel or
32Spreadsheet::XLSX
33
34For CSV this module uses Text::CSV_XS or Text::CSV_PP.
35
36For SquirrelCalc there is a very simplistic built-in parser
37
38%prep
39%setup -q -n %{pdir}-%{pnam}-%{version}
40
7abf5d48
JR
41%{__sed} -i -e '/#!\/pro\/bin\/perl/d' Read.pm
42%{__sed} -i -e 's|/pro/bin/perl|%{_bindir}/perl|' examples/*
43
c807ecde
JR
44%build
45AUTOMATED_TESTING=1 \
46%{__perl} Makefile.PL \
47 INSTALLDIRS=vendor
48
49%{__make}
50
51%{?with_tests:%{__make} test}
52
53%install
54rm -rf $RPM_BUILD_ROOT
55
56%{__make} pure_install \
57 DESTDIR=$RPM_BUILD_ROOT
58
59install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
67%doc Changes README
68%{perl_vendorlib}/Spreadsheet/Read*.pm
69%{_mandir}/man3/*
70%{_examplesdir}/%{name}-%{version}
This page took 0.112604 seconds and 4 git commands to generate.