]> git.pld-linux.org Git - packages/perl-Sereal-Encoder.git/blame_incremental - perl-Sereal-Encoder.spec
perl 5.38.0 rebuild
[packages/perl-Sereal-Encoder.git] / perl-Sereal-Encoder.spec
... / ...
CommitLineData
1# TODO: system libcsnappy, libminiz?
2#
3# Conditional build:
4%bcond_without tests # unit tests
5
6%define pdir Sereal
7%define pnam Encoder
8Summary: Sereal::Encoder - Fast, compact, powerful binary serialization
9Summary(pl.UTF-8): Sereal::Encoder - szybka, zwarta, potężna serializacja binarna
10Name: perl-Sereal-Encoder
11Version: 4.025
12Release: 2
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: https://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Encoder-%{version}.tar.gz
17# Source0-md5: feaedc77816634c6d6681c0b971eceb9
18URL: https://metacpan.org/release/Sereal-Encoder
19BuildRequires: perl-ExtUtils-MakeMaker >= 7.0
20BuildRequires: perl-ExtUtils-ParseXS >= 2.21
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
23BuildRequires: rpmbuild(macros) >= 1.745
24BuildRequires: zstd-devel
25%if %{with tests}
26BuildRequires: perl-Scalar-List-Utils
27BuildRequires: perl-Sereal-Decoder >= 4.002
28BuildRequires: perl-Test-Deep
29BuildRequires: perl-Test-Differences
30BuildRequires: perl-Test-LongString
31BuildRequires: perl-Test-Simple >= 0.88
32BuildRequires: perl-Test-Warn
33%endif
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37This library implements an efficient, compact-output, and feature-rich
38serializer using a binary protocol called Sereal. Its sister module
39Sereal::Decoder implements a decoder for this format. The two are
40released separately to allow for independent and safer upgrading. If
41you care greatly about performance, consider reading the
42Sereal::Performance documentation.
43
44The Sereal protocol version emitted by this encoder implementation is
45currently protocol version 3 by default.
46
47The protocol specification and many other bits of documentation can be
48found in the github repository at <https://github.com/Sereal/Sereal>.
49
50%description -l pl.UTF-8
51Ten moduł implementuje wydajny, mający zwarte wyjście i wiele
52możliwości, serializer wykorzystujący binary protokół o nazwie Sereal.
53Siostrzany moduł Sereal::Decoder implementuje dekoder dla tego
54formatu. Moduły wydawane są osobno, aby umożliwić niezależne i
55bezpieczniejsze aktualizacje. Informacje na temat wydajności można
56znaleźć w dokumentacji Sereal::Performance.
57
58Ta implementacja kodera domyślnie produkuje wyjście zgodne z
59protokołem Sereal w wersji 3.
60
61Specyfikację protokołu i inną dokumentację można znaleźć w
62repozytorium github <https://github.com/Sereal/Sereal>.
63
64%prep
65%setup -q -n %{pdir}-%{pnam}-%{version}
66
67%build
68%{__perl} Makefile.PL \
69 INSTALLDIRS=vendor
70%{__make} -j1 \
71 CC="%{__cc}" \
72 OPTIMIZE="%{rpmcflags}"
73
74%{?with_tests:%{__make} test}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78%{__make} pure_install \
79 DESTDIR=$RPM_BUILD_ROOT
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
86%doc Changes
87%dir %{perl_vendorarch}/Sereal
88%{perl_vendorarch}/Sereal/Encoder.pm
89%dir %{perl_vendorarch}/Sereal/Encoder
90%{perl_vendorarch}/Sereal/Encoder/*.pm
91%dir %{perl_vendorarch}/auto/Sereal
92%dir %{perl_vendorarch}/auto/Sereal/Encoder
93%attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Encoder/Encoder.so
94%{_mandir}/man3/Sereal::Encoder.3pm*
This page took 0.031929 seconds and 4 git commands to generate.