]> git.pld-linux.org Git - packages/perl-Sereal-Encoder.git/blame_incremental - perl-Sereal-Encoder.spec
rebuild with perl 5.32
[packages/perl-Sereal-Encoder.git] / perl-Sereal-Encoder.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Sereal
6%define pnam Encoder
7Summary: Sereal::Encoder - Fast, compact, powerful binary serialization
8Summary(pl.UTF-8): Sereal::Encoder - szybka, zwarta, potężna serializacja binarna
9Name: perl-Sereal-Encoder
10Version: 4.005
11Release: 4
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Encoder-%{version}.tar.gz
16# Source0-md5: 5af0152a2c7f13e7ae1d23952a55dd03
17URL: http://search.cpan.org/dist/Sereal-Encoder/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-Sereal-Decoder >= 3.00
22BuildRequires: perl-Test-LongString
23BuildRequires: perl-Test-Warn
24%endif
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28This library implements an efficient, compact-output, and feature-rich
29serializer using a binary protocol called Sereal. Its sister module
30Sereal::Decoder implements a decoder for this format. The two are
31released separately to allow for independent and safer upgrading. If
32you care greatly about performance, consider reading the
33Sereal::Performance documentation.
34
35The Sereal protocol version emitted by this encoder implementation is
36currently protocol version 3 by default.
37
38The protocol specification and many other bits of documentation can be
39found in the github repository at <https://github.com/Sereal/Sereal>.
40
41%description -l pl.UTF-8
42Ten moduł implementuje wydajny, mający zwarte wyjście i wiele
43możliwości, serializer wykorzystujący binary protokół o nazwie Sereal.
44Siostrzany moduł Sereal::Decoder implementuje dekoder dla tego
45formatu. Moduły wydawane są osobno, aby umożliwić niezależne i
46bezpieczniejsze aktualizacje. Informacje na temat wydajności można
47znaleźć w dokumentacji Sereal::Performance.
48
49Ta implementacja kodera domyślnie produkuje wyjście zgodne z
50protokołem Sereal w wersji 3.
51
52Specyfikację protokołu i inną dokumentację można znaleźć w
53repozytorium github <https://github.com/Sereal/Sereal>.
54
55%prep
56%setup -q -n %{pdir}-%{pnam}-%{version}
57
58%build
59%{__perl} Makefile.PL \
60 INSTALLDIRS=vendor
61%{__make} -j1 \
62 CC="%{__cc}" \
63 OPTIMIZE="%{rpmcflags}"
64
65%{?with_tests:%{__make} test}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69%{__make} pure_install \
70 DESTDIR=$RPM_BUILD_ROOT
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%files
76%defattr(644,root,root,755)
77%doc Changes
78%dir %{perl_vendorarch}/Sereal
79%{perl_vendorarch}/Sereal/Encoder.pm
80%dir %{perl_vendorarch}/Sereal/Encoder
81%{perl_vendorarch}/Sereal/Encoder/*.pm
82%dir %{perl_vendorarch}/auto/Sereal
83%dir %{perl_vendorarch}/auto/Sereal/Encoder
84%attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Encoder/Encoder.so
85%{_mandir}/man3/Sereal::Encoder.3pm*
This page took 0.079074 seconds and 4 git commands to generate.