]> git.pld-linux.org Git - packages/perl-Search-Xapian.git/blame_incremental - perl-Search-Xapian.spec
perl 5.38.0 rebuild
[packages/perl-Search-Xapian.git] / perl-Search-Xapian.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Search
6%define pnam Xapian
7%define basever 1.2.24
8Summary: Search::Xapian - Perl XS frontend to the Xapian C++ search library
9Summary(pl.UTF-8): Search::Xapian - interfejs Perlowy XS do biblioteki wyszukiwania Xapian
10Name: perl-Search-Xapian
11Version: %{basever}.0
12Release: 6
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16#Source0: http://www.cpan.org/modules/by-module/Search/%{pdir}-%{pnam}-%{version}.tar.gz
17Source0: http://oligarchy.co.uk/xapian/%{basever}/%{pdir}-%{pnam}-%{version}.tar.gz
18# Source0-md5: 01206bf2cc71c5b3a6258a01daabfc43
19URL: http://search.cpan.org/dist/Search-Xapian/
20BuildRequires: libstdc++-devel
21%if %{with tests}
22BuildRequires: perl-Devel-Leak
23%endif
24BuildRequires: perl-devel >= 1:5.8.0
25BuildRequires: rpm-perlprov >= 4.1-13
26BuildRequires: xapian-core-devel >= %{basever}
27Requires: xapian-core-libs >= %{basever}
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31This module wraps most methods of most Xapian classes. The missing
32classes and methods should be added in the future. It also provides a
33simplified, more 'perlish' interface to some common operations.
34
35%description -l pl.UTF-8
36Ten moduł obudowuje większość metod z większości klas Xapiana.
37Brakujące klasy i metody powinny być dodane w przyszłości. Moduł
38udostępnia także uproszczony, bardziej perlowy interfejs do niektórych
39popularnych operacji.
40
41%prep
42%setup -q -n %{pdir}-%{pnam}-%{version}
43
44%build
45%{__perl} Makefile.PL \
46 INSTALLDIRS=vendor
47
48# NOTE: (this) Perl build system doesn't have CXX, but CC is used
49%{__make} \
50 CC="%{__cxx}" \
51 OPTIMIZE="%{rpmcxxflags}"
52
53%{?with_tests:%{__make} test}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} pure_install \
59 DESTDIR=$RPM_BUILD_ROOT
60
61install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc Changes README
70%dir %{perl_vendorarch}/Search
71%{perl_vendorarch}/Search/Xapian.pm
72%dir %{perl_vendorarch}/Search/Xapian
73%{perl_vendorarch}/Search/Xapian/*.pm
74%dir %{perl_vendorarch}/Search/Xapian/MSet
75%{perl_vendorarch}/Search/Xapian/MSet/Tied.pm
76%dir %{perl_vendorarch}/auto/Search
77%dir %{perl_vendorarch}/auto/Search/Xapian
78%attr(755,root,root) %{perl_vendorarch}/auto/Search/Xapian/Xapian.so
79%{_mandir}/man3/Search::Xapian*.3pm*
80%{_examplesdir}/%{name}-%{version}
This page took 0.091668 seconds and 4 git commands to generate.