]> git.pld-linux.org Git - packages/perl-Readonly.git/blobdiff - perl-Readonly.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Readonly.git] / perl-Readonly.spec
index bd4b887590805790d2942a74e7d76da75ce011ae..753b3ca242046774599612206b8b25cf865b2792 100644 (file)
@@ -1,55 +1,64 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
+%bcond_without tests   # do not perform "make test"
 #
-%include       /usr/lib/rpm/macros.perl
-%define        pdir    Readonly
-Summary:       Readonly - Facility for creating read-only scalars, arrays, hashes.
-#Summary(pl):  Readonly
+%define                pdir    Readonly
+Summary:       Readonly - facility for creating read-only scalars, arrays, hashes
+Summary(pl.UTF-8):     Readonly - udogodnienie do tworzenia zmiennych tylko do odczytu
 Name:          perl-Readonly
-Version:       0.07
+Version:       2.05
 Release:       1
-License:       GPL/Artistic
+# same as perl 5
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/authors/id/R/RO/ROODE/%{pdir}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6.1
-%if %{?_without_tests:0}%{!?_without_tests:1}
+Source0:       http://www.cpan.org/modules/by-authors/id/S/SA/SANKO/%{pdir}-%{version}.tar.gz
+# Source0-md5: acae851d7d55c509f5f00a8849597e54
+URL:           http://search.cpan.org/dist/Readonly/
+BuildRequires: perl-Module-Build-Tiny >= 0.035
+BuildRequires: perl-devel >= 1:5.8.1
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
 BuildRequires: perl-Test-Simple
 BuildRequires: perl-Test-Harness
 %endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-
 %description
-This is a facility for creating non-modifiable variables.  This is
-useful for configuration files, headers, etc.  It can also be useful as
-a development and debugging tool, for catching updates to variables that
-should not be changed.
+This is a facility for creating non-modifiable variables. This is
+useful for configuration files, headers, etc. It can also be useful as
+a development and debugging tool, for catching updates to variables
+that should not be changed.
 
-# %description -l pl
-# TODO
+%description -l pl.UTF-8
+Readonly umożliwia tworzenie niemodyfikowalnych zmiennych.  Jest to
+użyteczne w plikach konfiguracyjnych, nagłówkach, itp.  Może być także
+przydatne jako narzędzie do rozwijania programów i wyszukiwania
+błędów, wyłapując próby zapisu do zmiennych, które nie powinny być
+zmieniane.
 
 %prep
 %setup -q -n %{pdir}-%{version}
 
 %build
-perl Makefile.PL
-%{__make}
+%{__perl} Build.PL
+
+./Build
 
-%{!?_without_tests:%{__make} test}
+%{?with_tests:./Build test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+./Build install \
+       --destdir=$RPM_BUILD_ROOT \
+       --installdirs=vendor
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc Changes README
-%{perl_sitelib}/*.pm
-%{_mandir}/man3/*
+%doc Changes README.md
+%{perl_vendorlib}/Readonly.pm
+%{_mandir}/man3/Readonly.3pm*
This page took 1.162219 seconds and 4 git commands to generate.