]> git.pld-linux.org Git - packages/perl-Proc-Background.git/blobdiff - perl-Proc-Background.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Proc-Background.git] / perl-Proc-Background.spec
index 994db4821a1abf78e21c21e0a8c237756945aeba..cc95d74c5f078a2abb0fc20d3a6c45724902d0a6 100644 (file)
@@ -1,50 +1,67 @@
-%define        pdir    Proc
-%define        pnam    Background
-%include       /usr/lib/rpm/macros.perl
-Summary:       Proc-Background perl module
-Summary(pl):   Modu³ perla Proc-Background
-Name:          perl-Proc-Background
-Version:       1.06
-Release:       3
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
 
-License:       GPL
+%define                pdir    Proc
+%define                pnam    Background
+Summary:       Proc::Background Perl module - generic interface to background process management
+Summary(pl.UTF-8):     Moduł Perla Proc::Background - ogólny interfejs do zarządzania procesami w tle
+Name:          perl-Proc-Background
+Version:       1.10
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 4f9d850e31c4131d1a28ffe0d26ef4e2
+URL:           http://search.cpan.org/dist/Proc-Background/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
 Provides:      perl(Proc::Generic)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Proc-Background - generic interface to place programs in background
-processing.
+Proc::Background Perl module is a generic interface for placing
+processes in the background on Unix platforms. This module lets you
+start, kill, wait on, retrieve exit values, and see if background
+processes still exist.
 
-%description -l pl
-Proc-Background - umo¿liwia uruchamianie pogramów w tle.
+%description -l pl.UTF-8
+Moduł Perla Proc::Background stanowi podstawowy interfejs dla
+umieszczania procesów w tle na platformach uniksowych. Moduł ten
+umożliwia uruchamianie, zabijanie procesów, oczekiwanie na ich
+zakończenie i odbieranie kodu powrotu procesu. Za jego pomocą można
+też zobaczyć, jakie procesy nadal działają w tle.
 
 %prep
-%setup -q -n Proc-Background-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-gzip -9nf CHANGES README
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
+%doc Changes README
 %attr(755,root,root) %{_bindir}/timed-process
-%{perl_sitelib}/Proc/Background.pm
-%{perl_sitelib}/Proc/Background/Unix.pm
-%{perl_sitelib}/Proc/Background/Win32.pm
-%{_mandir}/man[13]/*
+%{perl_vendorlib}/Proc/Background.pm
+%dir %{perl_vendorlib}/Proc/Background
+%{perl_vendorlib}/Proc/Background/Unix.pm
+#%%{perl_vendorlib}/Proc/Background/Win32.pm
+%{_mandir}/man1/*
+%{_mandir}/man3/Proc::Background.*
+%{_mandir}/man3/Proc::Background::Unix*
+#%%{_mandir}/man3/Proc::Background::Win32*
This page took 0.092722 seconds and 4 git commands to generate.