]> git.pld-linux.org Git - packages/perl-Plack.git/blame - perl-Plack.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Plack.git] / perl-Plack.spec
CommitLineData
01cccd88 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Plack
01cccd88 6Summary: Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
01cccd88 7Name: perl-Plack
2a588ecc 8Version: 1.0047
6252cec1 9Release: 1
01cccd88 10# same as perl
11License: GPL v1+ or Artistic
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
2a588ecc 14# Source0-md5: 9d37086aec1b29bab52a9575687e3557
01cccd88 15URL: http://search.cpan.org/dist/Plack/
16BuildRequires: perl-devel >= 1:5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
76d6d790 18BuildRequires: perl-File-ShareDir-Install
01cccd88 19%if %{with tests}
20BuildRequires: perl(Devel::StackTrace::AsHTML) >= 0.11
21BuildRequires: perl(Filesys::Notify::Simple)
22BuildRequires: perl(HTTP::Body) >= 1.06
23BuildRequires: perl(Hash::MultiValue) >= 0.05
24BuildRequires: perl(Test::Requires)
25BuildRequires: perl(Test::TCP) >= 0.11
02da70bc 26BuildRequires: perl-Apache-LogFormat-Compiler
01cccd88 27BuildRequires: perl-Devel-StackTrace >= 1.23
28BuildRequires: perl-File-ShareDir >= 1.00
e4d9e053 29BuildRequires: perl-HTTP-Entity-Parser
01cccd88 30BuildRequires: perl-HTTP-Request-AsCGI
02da70bc 31BuildRequires: perl-Stream-Buffered
01cccd88 32BuildRequires: perl-Try-Tiny
33BuildRequires: perl-URI >= 1.36
34BuildRequires: perl-libwww >= 5.814
35%endif
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
34dedfd0 39%define _noautoreq_perl 'Apache::Constants' 'Apache::Request'
01cccd88 40
41%description
42Plack is a set of tools for using the PSGI stack. It contains
43middleware components, a reference server and utilities for Web
44application frameworks. Plack is like Ruby's Rack or Python's Paste
45for WSGI.
46
47See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
48and Plack are and why we need them.
49
01cccd88 50%prep
51%setup -q -n %{pdir}-%{version}
01cccd88 52
53%build
54%{__perl} Makefile.PL \
55 INSTALLDIRS=vendor
56%{__make}
57
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} pure_install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
73%defattr(644,root,root,755)
74%doc Changes README
75%{perl_vendorlib}/*.pm
76%{perl_vendorlib}/Plack/
77%{_mandir}/man1/*
78%{_mandir}/man3/*
79%{_examplesdir}/%{name}-%{version}
80%attr(755,root,root) %{_bindir}/plackup
81%{perl_vendorlib}/HTTP/Message/PSGI.pm
82%{perl_vendorlib}/HTTP/Server/PSGI.pm
83%{perl_vendorlib}/auto/share/dist/Plack
This page took 0.092149 seconds and 4 git commands to generate.