]> git.pld-linux.org Git - packages/perl-Pegex.git/blame - perl-Pegex.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Pegex.git] / perl-Pegex.spec
CommitLineData
1cd78012
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Pegex
1cd78012
JB
6Summary: Pegex - Acmeist PEG Parser Framework
7Summary(pl.UTF-8): Pegex - szkielet analizatora Acmeist PEG
8Name: perl-Pegex
9Version: 0.60
10Release: 1
11# same as perl
12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-authors/id/I/IN/INGY/%{pdir}-%{version}.tar.gz
15# Source0-md5: 347f72c1c0347148d80058ea35927df8
16URL: http://search.cpan.org/dist/Pegex/
17BuildRequires: perl-File-ShareDir-Install >= 0.06
18BuildRequires: perl-devel >= 1:5.8.1
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-YAML-LibYAML
22%endif
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Pegex is an Acmeist parser framework. It allows you to easily create
28parsers that will work equivalently in lots of programming languages!
29The inspiration for Pegex comes from the parsing engine upon which the
30postmodern programming language Perl 6 is based on. Pegex brings this
31beauty to the other justmodern languages that have a normal regular
32expression engine available.
33
34Pegex gets it name by combining Parsing Expression Grammars (PEG),
35with Regular Expessions (Regex). That's actually what Pegex does.
36
37%description -l pl.UTF-8
38Pegex to szkielet analizatora Acmeist. Pozwala łatwo tworzyć
39analizatory działające tak samo w wielu językach programowania. Pegex
40jest zainspirowany silnikiem analizującym, na którym jest oparty
41postmodernistyczny język Perl 6. Pegex dostarcza o piękno do innych
42współczesnych języków, mających dostępny zwykły silnik wyrażeń
43regularnych.
44
45Nazwa Pegex pochodzi z połączenia skrótu PEG (Parsing Expression
46Grammars) z Regex (Regular Expressions). I oznacza to, co właściwie
47Pegex robi.
48
49%prep
50%setup -q -n %{pdir}-%{version}
51
52%build
53%{__perl} Makefile.PL \
54 INSTALLDIRS=vendor
55%{__make}
56
57%{?with_tests:%{__make} test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%{__make} pure_install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Pegex.pod
66
67install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%files
74%defattr(644,root,root,755)
75%doc Changes
76%{perl_vendorlib}/Pegex.pm
77%{perl_vendorlib}/Pegex
78%{perl_vendorlib}/auto/share/dist/Pegex
79%{_mandir}/man3/Pegex.3pm*
80%{_mandir}/man3/Pegex::*.3pm*
81%{_examplesdir}/%{name}-%{version}
This page took 0.07911 seconds and 4 git commands to generate.