]> git.pld-linux.org Git - packages/perl-Params-Classify.git/blame_incremental - perl-Params-Classify.spec
rebuild with perl 5.34.0
[packages/perl-Params-Classify.git] / perl-Params-Classify.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Params
6%define pnam Classify
7Summary: Params::Classify - argument type classification
8Summary(pl.UTF-8): Params::Classify - klasyfikacja typu argumentu
9Name: perl-Params-Classify
10Version: 0.015
11Release: 4
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Params/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 3c3367d759ed5bd6fe86c1f35e9b51ed
17URL: https://metacpan.org/dist/Params-Classify
18BuildRequires: perl-ExtUtils-ParseXS >= 2.2006
19BuildRequires: perl-Module-Build >= 0.33
20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
22BuildRequires: rpmbuild(macros) >= 1.745
23%if %{with tests}
24BuildRequires: perl-Scalar-List-Utils >= 1.01
25BuildRequires: perl-Test-Simple
26%endif
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30This module provides various type-testing functions. These are
31intended for functions that, unlike most Perl code, care what type of
32data they are operating on. For example, some functions wish to
33behave differently depending on the type of their arguments (like
34overloaded functions in C++).
35
36%description -l pl.UTF-8
37Ten moduł udostępnia różne funkcje do sprawdzania typów. Mają być
38przydatne dla funkcji, które - w przeciwieństwie do większości kodu
39perlowego - zwracają uwagę na typ danych, na których operują; np.
40dla funkcji, które zachowują się różnie w zależności od typu
41argumentów (jak przeciążone funkcje w C++).
42
43%prep
44%setup -q -n %{pdir}-%{pnam}-%{version}
45
46%build
47%{__perl} Build.PL \
48 installdirs=vendor \
49 --config cc="%{__cc}" \
50 --config ld="%{__cc}" \
51 --config optimize="%{rpmcflags}"
52
53./Build
54
55%{?with_tests:./Build test}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59
60./Build install \
61 destdir=$RPM_BUILD_ROOT
62
63%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Params/Classify/Classify.bs
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc Changes README
71%{perl_vendorarch}/Params/Classify.pm
72%dir %{perl_vendorarch}/auto/Params/Classify
73%attr(755,root,root) %{perl_vendorarch}/auto/Params/Classify/Classify.so
74%{_mandir}/man3/Params::Classify.3pm*
This page took 0.102874 seconds and 4 git commands to generate.