]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blame_incremental - perl-Net-SSH-Perl.spec
- rel 1
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Net
7%define pnam SSH-Perl
8Summary: Net::SSH::Perl - Perl client Interface to SSH
9Summary(pl.UTF-8): Net::SSH::Perl - perlowy interfejs kliencki do SSH
10Name: perl-Net-SSH-Perl
11Version: 1.34
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 5b6d60e459707058e856c45c30e96e53
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-Convert-PEM >= 0.05
22BuildRequires: perl-Crypt-DH >= 0.01
23BuildRequires: perl-Crypt-DSA >= 0.11
24BuildRequires: perl-Digest-HMAC
25BuildRequires: perl-Digest-MD5
26BuildRequires: perl-Digest-SHA1 >= 2.10
27BuildRequires: perl-Math-GMP >= 1.04
28BuildRequires: perl-Math-Pari >= 2.001804
29BuildRequires: perl-MIME-Base64
30BuildRequires: perl-Scalar-List-Utils
31BuildRequires: perl-String-CRC32 >= 1.2
32%endif
33Requires: perl-Convert-PEM >= 0.05
34Requires: perl-Crypt-Blowfish
35Requires: perl-Crypt-DES
36Requires: perl-Crypt-DH >= 0.01
37Requires: perl-Crypt-DSA >= 0.11
38Requires: perl-Crypt-IDEA
39Requires: perl-Crypt-RSA
40Requires: perl-Digest-BubbleBabble
41Requires: perl-Digest-HMAC
42Requires: perl-Digest-MD5
43Requires: perl-Digest-SHA1 >= 2.10
44Requires: perl-Math-GMP >= 1.04
45Requires: perl-Math-Pari >= 2.001804
46Requires: perl-MIME-Base64
47Requires: perl-Scalar-List-Utils
48Requires: perl-String-CRC32 >= 1.2
49BuildArch: noarch
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
54Shell) client. It is compatible with both the SSH-1 and SSH-2
55protocols.
56
57%description -l pl.UTF-8
58Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
59klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
60SSH-1 jak i SSH-2.
61
62%prep
63%setup -q -n %{pdir}-%{pnam}-%{version}
64
65%build
66%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Perl::Net::SSH::Perl")' \
67 INSTALLDIRS=vendor
68%{__make}
69
70%{?with_tests:%{__make} test}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75%{__make} install \
76 DESTDIR=$RPM_BUILD_ROOT
77
78install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
86%doc Changes ToDo
87%dir %{perl_vendorlib}/Net/SSH
88%{perl_vendorlib}/Net/SSH/*.pm
89%{perl_vendorlib}/Net/SSH/Perl
90%{_mandir}/man3/*
91%{_examplesdir}/%{name}-%{version}
This page took 0.045263 seconds and 4 git commands to generate.