]> git.pld-linux.org Git - packages/perl-Net-OAuth.git/blame - perl-Net-OAuth.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-OAuth.git] / perl-Net-OAuth.spec
CommitLineData
7059dd18 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Net
6%define pnam OAuth
7059dd18 7Summary: Net::OAuth - OAuth protocol support
8#Summary(pl.UTF-8):
9Name: perl-Net-OAuth
eaa56dda 10Version: 0.28
7059dd18 11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/K/KG/KGRENNAN/Net-OAuth-%{version}.tar.gz
eaa56dda 16# Source0-md5: 336d7fb22e945f014e1bce0f49fcfad9
fde6887a 17URL: http://search.cpan.org/dist/Net-OAuth/
7059dd18 18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-Class-Accessor >= 0.31
22BuildRequires: perl-Class-Data-Inheritable >= 0.06
23BuildRequires: perl-Digest-HMAC >= 1.01
24BuildRequires: perl-Digest-SHA1 >= 2.12
fde6887a 25BuildRequires: perl-Encode
7059dd18 26BuildRequires: perl-Test-Warn >= 0.21
fde6887a 27BuildRequires: perl-URI
7059dd18 28%endif
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33An OAuth message is a set of key-value pairs. The following message
34types are supported:
35- Requests
36- Responses
37
38Each OAuth message type has one or more required parameters, zero or
39more optional parameters, and most allow arbitrary parameters.
40
41All OAuth requests must be signed by the Consumer. Responses from the
42Service Provider, however, are not signed.
43
44# %description -l pl.UTF-8
45# TODO
46
47%prep
48%setup -q -n %{pdir}-%{pnam}-%{version}
49
50%build
fde6887a 51%{__perl} Build.PL \
52 destdir=$RPM_BUILD_ROOT \
53 installdirs=vendor
54./Build
7059dd18 55
fde6887a 56%{?with_tests:./Build test}
7059dd18 57
58%install
59rm -rf $RPM_BUILD_ROOT
60
fde6887a 61./Build install
7059dd18 62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc Changes README
69%{perl_vendorlib}/Net/*.pm
70%{perl_vendorlib}/Net/OAuth
71%{_mandir}/man3/*
This page took 0.129044 seconds and 4 git commands to generate.