]> git.pld-linux.org Git - packages/perl-Module-Install.git/blame - perl-Module-Install.spec
- tabs in preamble
[packages/perl-Module-Install.git] / perl-Module-Install.spec
CommitLineData
9b82a0b9 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Module
7%define pnam Install
8Summary: Module::Install - Standalone, extensible Perl module installer
6a4e84c6 9Summary(pl.UTF-8): Module::Install - samodzielny, rozszerzalny instalator modułów Perla
9b82a0b9 10Name: perl-Module-Install
11Version: 0.63
12Release: 0.1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
8876c945 16Source0: http://www.cpan.org/modules/by-authors/id/A/AD/ADAMK/%{pdir}-%{pnam}-%{version}.tar.gz
9b82a0b9 17# Source0-md5: d2404a019eaf149eaa34db65ab8fb72d
8876c945 18URL: http://search.cpan.org/dist/Module-Install/
9b82a0b9 19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-YAML >= 0.35
23%endif
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
9b82a0b9 27%description
28Module::Install is a package for writing installers for CPAN (or
29CPAN-like) distributions that are clean, simple, minimalist, act in a
30strictly correct manner with both the ExtUtils::MakeMaker and
31Module::Build build systems, and will run on any Perl installation
32version 5.004 or newer.
33
34The intent is to make it as easy as possible for CPAN authors (and
35especially for first-time CPAN authors) to have installers that follow
36all the best practices for distribution installation, but involve as
37much DWIM (Do What I Mean) as possible when writing them.
38
7f3505fe 39%description -l pl.UTF-8
8876c945 40Module::Install to pakiet do pisania dla dystrybucji CPAN (lub
7f3505fe
JR
41podobnych) instalatorów, które będą przejrzyste, minimalistyczne i
42działały całkowicie poprawnie z systemami budowania
43ExtUtils::MakeMaker i Module::Build, a także będą działać na każdej
8876c945
JB
44instalacji Perla od wersji 5.004.
45
7f3505fe
JR
46Celem jest jak największe ułatwienie autorom CPAN (a szczególnie
47początkującym autorom CPAN) posiadania instalatorów zachowujących się
8876c945 48jak najlepiej.
9b82a0b9 49
50%prep
51%setup -q -n %{pdir}-%{pnam}-%{version}
52
53%build
54%{__perl} Makefile.PL \
55 --skipdeps \
56 INSTALLDIRS=vendor
57%{__make}
58
59%{?with_tests:%{__make} test}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64%{__make} install \
65 DESTDIR=$RPM_BUILD_ROOT
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
72%doc Changes README
73%{perl_vendorlib}/Module/*.pm
74%{perl_vendorlib}/Module/Install
75%{perl_vendorlib}/inc
76%{_mandir}/man3/*
This page took 0.09756 seconds and 4 git commands to generate.