]> git.pld-linux.org Git - packages/perl-Math-PRSG.git/blobdiff - perl-Math-PRSG.spec
- rebuild with perl 5.26
[packages/perl-Math-PRSG.git] / perl-Math-PRSG.spec
index d0d4517d082985cb24979136ff1b21851e17cd43..da7724e1ac22cd2d980757ff5011f36be9a08a2c 100644 (file)
@@ -3,37 +3,48 @@
 %bcond_without tests   # do not perform "make test"
 #
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Math
-%define        pnam    PRSG
-Summary:       Math::PRSG perl module
-Summary(pl):   Modu³ perla Math::PRSG
+%define                pdir    Math
+%define                pnam    PRSG
+Summary:       Math::PRSG - Perl interface to pseudo random sequence generator function
+Summary(pl.UTF-8):     Math::PRSG - interfejs Perla do funkcji generatora ciągów pseudolosowych
 Name:          perl-Math-PRSG
 Version:       1.0
-Release:       8
+Release:       18
 # if used in a product, Systemics should be given attribution as the author
 License:       free use, distributable
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+Source0:       http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
 # Source0-md5: 4f0c32973d5b03d2a665b6ac6ec04b9c
 Patch0:                %{name}-paths.patch
+URL:           http://search.cpan.org/dist/Math-PRSG/
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
-BuildRequires: perl-devel >= 5.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Math::PRSG - interface to pseudo random sequence generator function.
+Math::PRSG is a Perl interface to pseudo random sequence generator
+function. It implements a (159, 31, 0) LFSR, giving a period of 160
+bits. This can then be used as a RNG if seeded well (ie. with 160 bits
+of entropy) and if the output is fed through a message digest function
+(in order to prevent any prediction).
 
-%description -l pl
-Math::PRSG - interfejs do funkcji generowania pseudolosowych sekwencji.
+%description -l pl.UTF-8
+Math::PRSG to perlowy interfejs do funkcji generatora ciągów
+pseudolosowych. Implementuje funkcję LFSR (159, 31, 0) mającą okres
+160-bitowy. Może być używany jako generator liczb losowych jeśli
+zostanie dobrze zasilony (160 bitami entropii), a wyjście jest
+przekazywane przez funkcję skrótu (w celu uniknięcia
+przewidywalności).
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
-%patch -p1
+%patch0 -p1
 
 %build
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 %{__make} \
+       CC="%{__cc}" \
        OPTIMIZE="%{rpmcflags}"
 
 %{?with_tests:%{__make} test}
@@ -41,7 +52,8 @@ Math::PRSG - interfejs do funkcji generowania pseudolosowych sekwencji.
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -51,6 +63,5 @@ rm -rf $RPM_BUILD_ROOT
 %doc examples/prsg_driver.pl
 %{perl_vendorarch}/Math/PRSG.pm
 %dir %{perl_vendorarch}/auto/Math/PRSG
-%{perl_vendorarch}/auto/Math/PRSG/PRSG.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Math/PRSG/PRSG.so
 %{_mandir}/man3/*
This page took 0.109173 seconds and 4 git commands to generate.