]> git.pld-linux.org Git - packages/perl-Math-PRSG.git/blobdiff - perl-Math-PRSG.spec
- release 11
[packages/perl-Math-PRSG.git] / perl-Math-PRSG.spec
index ea15ed0eecfe423b74a36fc89fe9635a2361af9f..896b27d6b5b7263835b66becf2c63f9a46aed0fe 100644 (file)
@@ -1,39 +1,59 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Math
-%define        pnam    PRSG
-Summary:       Math::PRSG perl module
-Summary(pl):   Modu³ perla Math::PRSG
+%define                pdir    Math
+%define                pnam    PRSG
+Summary:       Math::PRSG - Perl interface to pseudo random sequence generator function
+Summary(pl.UTF-8):     Math::PRSG - interfejs Perla do funkcji generatora ciągów pseudolosowych
 Name:          perl-Math-PRSG
 Version:       1.0
-Release:       8
-License:       GPL
+Release:       11
+# if used in a product, Systemics should be given attribution as the author
+License:       free use, distributable
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+Source0:       http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
 # Source0-md5: 4f0c32973d5b03d2a665b6ac6ec04b9c
 Patch0:                %{name}-paths.patch
+URL:           http://search.cpan.org/dist/Math-PRSG/
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
-BuildRequires: perl-devel >= 5.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Math::PRSG - interface to pseudo random sequence generator function.
+Math::PRSG is a Perl interface to pseudo random sequence generator
+function. It implements a (159, 31, 0) LFSR, giving a period of 160
+bits. This can then be used as a RNG if seeded well (ie. with 160 bits
+of entropy) and if the output is fed through a message digest function
+(in order to prevent any prediction).
 
-%description -l pl
-Math::PRSG - interfejs do funkcji generowania pseudolosowych sekwencji.
+%description -l pl.UTF-8
+Math::PRSG to perlowy interfejs do funkcji generatora ciągów
+pseudolosowych. Implementuje funkcję LFSR (159, 31, 0) mającą okres
+160-bitowy. Może być używany jako generator liczb losowych jeśli
+zostanie dobrze zasilony (160 bitami entropii), a wyjście jest
+przekazywane przez funkcję skrótu (w celu uniknięcia
+przewidywalności).
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
-%patch -p1
+%patch0 -p1
 
 %build
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__make} \
+       CC="%{__cc}" \
+       OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.220832 seconds and 4 git commands to generate.