]> git.pld-linux.org Git - packages/perl-Math-PRSG.git/blobdiff - perl-Math-PRSG.spec
- rel. 9
[packages/perl-Math-PRSG.git] / perl-Math-PRSG.spec
index acdc48d8f94e426a481404e0fac6f6f771e7c52a..804a2988224fc133e3589181e234550f29b33638 100644 (file)
@@ -1,47 +1,48 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Math-PRSG perl module
-Summary(pl):   Modu³ perla Math-PRSG
+%define        pdir    Math
+%define        pnam    PRSG
+Summary:       Math::PRSG perl module
+Summary(pl):   Modu³ perla Math::PRSG
 Name:          perl-Math-PRSG
 Version:       1.0
-Release:       3
-Copyright:     GPL
+Release:       9
+# if used in a product, Systemics should be given attribution as the author
+License:       free use, distributable
 Group:         Development/Languages/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Source:                ftp://ftp.perl.org/pub/CPAN/modules/by-module/Math/Math-PRSG-%{version}.tar.gz
-Patch:         perl-Math-PRSG-paths.patch
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.005_03-14
-%requires_eq   perl
-Requires:      %{perl_sitearch}
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 4f0c32973d5b03d2a665b6ac6ec04b9c
+Patch0:                %{name}-paths.patch
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Math-PRSG - interface to pseudo random sequence generator function. 
+Math::PRSG - interface to pseudo random sequence generator function.
 
 %description -l pl
-Math-PRSG - interfejs do funkcji generowania pseudolosowych sekwencji.
+Math::PRSG - interfejs do funkcji generowania pseudolosowych sekwencji.
 
 %prep
-%setup -q -n Math-PRSG-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{version}
 %patch -p1
 
 %build
-perl Makefile.PL
-make OPTIMIZE="$RPM_OPT_FLAGS"
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT
-
-strip --strip-unneeded $RPM_BUILD_ROOT/%{perl_sitearch}/auto/Math/PRSG/*.so
-
-(
-  cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/Math/PRSG
-  sed -e "s#$RPM_BUILD_ROOT##" .packlist >.packlist.new
-  mv .packlist.new .packlist
-)
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/*
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -49,12 +50,8 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc examples/prsg_driver.pl
-
-%{perl_sitearch}/Math/PRSG.pm
-
-%dir %{perl_sitearch}/auto/Math/PRSG
-%{perl_sitearch}/auto/Math/PRSG/.packlist
-%{perl_sitearch}/auto/Math/PRSG/PRSG.bs
-%attr(755,root,root) %{perl_sitearch}/auto/Math/PRSG/PRSG.so
-
+%{perl_vendorarch}/Math/PRSG.pm
+%dir %{perl_vendorarch}/auto/Math/PRSG
+%{perl_vendorarch}/auto/Math/PRSG/PRSG.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Math/PRSG/PRSG.so
 %{_mandir}/man3/*
This page took 0.228282 seconds and 4 git commands to generate.