]> git.pld-linux.org Git - packages/perl-Math-Geometry-Voronoi.git/blame - perl-Math-Geometry-Voronoi.spec
perl 5.38.0 rebuild
[packages/perl-Math-Geometry-Voronoi.git] / perl-Math-Geometry-Voronoi.spec
CommitLineData
a3649d16
AM
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Math
6%define pnam Geometry-Voronoi
a3649d16
AM
7Summary: Math::Geometry::Voronoi - compute Voronoi diagrams from sets of points
8Name: perl-Math-Geometry-Voronoi
9Version: 1.3
e0cd8b01 10Release: 12
a3649d16
AM
11License: GPL v1+ or Artistic
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
14# Source0-md5: 44392be55ff56870aaff286dd735a5e2
15URL: http://search.cpan.org/dist/Math-Geometry-Voronoi/
16BuildRequires: perl-devel >= 1:5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18%if %{with tests}
19BuildRequires: perl-Class-Accessor
20BuildRequires: perl-Params-Validate
21%endif
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25This module computes Voronoi diagrams from a set of input points. Info
26on Voronoi diagrams can be found here:
27
28http://en.wikipedia.org/wiki/Voronoi_diagram
29
30This module is a wrapper around a C implementation found here:
31
32http://www.derekbradley.ca/voronoi.html
33
34Which is itself a modification of code by Steve Fortune, the inventor
35of the algorithm used (Fortune's algorithm):
36
37%prep
38%setup -q -n %{pdir}-%{pnam}-%{version}
39
40%build
41%{__perl} Makefile.PL \
42 INSTALLDIRS=vendor
43%{__make} \
44 CC="%{__cc}" \
45 OPTIMIZE="%{rpmcflags}"
46
47%{?with_tests:%{__make} test}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} pure_install \
53 DESTDIR=$RPM_BUILD_ROOT
54
55install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc Changes README
64%{perl_vendorarch}/Math/Geometry/Voronoi.pm
65%dir %{perl_vendorarch}/auto/Math/Geometry/Voronoi
66%attr(755,root,root) %{perl_vendorarch}/auto/Math/Geometry/Voronoi/Voronoi.so
67%{_mandir}/man3/*
68%{_examplesdir}/%{name}-%{version}
This page took 0.208929 seconds and 4 git commands to generate.