]> git.pld-linux.org Git - packages/perl-IO-Async.git/blame - perl-IO-Async.spec
- up to 0.39
[packages/perl-IO-Async.git] / perl-IO-Async.spec
CommitLineData
cf21eb9c 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir IO
7%define pnam Async
8Summary: IO::Async - perform asynchronous filehandle IO and other operations
36a9cfed 9Summary(pl.UTF-8): IO::Async - asynchroniczne operacje we/wy na plikach i inne
cf21eb9c 10Name: perl-IO-Async
36a9cfed 11Version: 0.39
cf21eb9c 12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
36a9cfed
JB
16Source0: http://www.cpan.org/modules/by-module/IO/PEVANS/IO-Async-%{version}.tar.gz
17# Source0-md5: 084f8f925827db81c64036afb05be9fb
cf21eb9c 18URL: http://search.cpan.org/dist/IO-Async/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
36a9cfed
JB
22BuildRequires: perl-Async-MergePoint
23BuildRequires: perl-CPS
24BuildRequires: perl-Heap >= 0.80
25BuildRequires: perl-Socket-GetAddrInfo >= 0.18
26BuildRequires: perl-Storable
27BuildRequires: perl-Time-HiRes
cf21eb9c 28BuildRequires: perl-Test-Exception
36a9cfed
JB
29BuildRequires: perl-Test-Fatal
30BuildRequires: perl-Test-Identity
31BuildRequires: perl-Test-Refcount
32BuildRequires: perl-Test-Warn
cf21eb9c 33%endif
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38This collection of modules allows programs to be written that perform
39asynchronous filehandle IO operations. A typical program using them
40would consist of a single subclass of IO::Async::Loop to act as a
36a9cfed
JB
41container of other objects, which perform the actual IO work required
42by the program. As well as IO handles, the loop also supports timers
43and signal handlers, and includes more higher-level functionallity
44built on top of these basic parts.
cf21eb9c 45
36a9cfed
JB
46%description -l pl.UTF-8
47Zestaw modułów umożliwiających pisanie programów wykonywanie
48asynchroncznych operacji we/wy na uchwytach plików. Typowy program
49wykonujący je składa się z pojedynczej podklasy IO::Async::Loop
50pełniącej rolę kontenera innych obiektów, wykonujących właściwe
51operacje we/wy wymagane przez program. Oprócz obsługi we/wy pętla
52obsługuje także stopery i sygnały, a także zawiera nieco funkcji
53wyższego poziomu stworzonych w oparciu o te podstawowe elementy.
cf21eb9c 54
55%prep
56%setup -q -n %{pdir}-%{pnam}-%{version}
57
58%build
59%{__perl} Build.PL \
60 destdir=$RPM_BUILD_ROOT \
61 installdirs=vendor
62./Build
63
64%{?with_tests:./Build test}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69./Build install
70
71install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(644,root,root,755)
79%doc Changes README
36a9cfed 80%{perl_vendorlib}/IO/Async.pm
cf21eb9c 81%{perl_vendorlib}/IO/Async
36a9cfed 82%{_mandir}/man3/IO::Async*.3pm*
cf21eb9c 83%{_examplesdir}/%{name}-%{version}
This page took 0.080123 seconds and 4 git commands to generate.