]> git.pld-linux.org Git - packages/perl-IO-Async.git/blame - perl-IO-Async.spec
- updated to 0.27
[packages/perl-IO-Async.git] / perl-IO-Async.spec
CommitLineData
cf21eb9c 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir IO
7%define pnam Async
8Summary: IO::Async - perform asynchronous filehandle IO and other operations
9#Summary(pl.UTF-8):
10Name: perl-IO-Async
77f0feb2 11Version: 0.27
cf21eb9c 12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/IO-Async-%{version}.tar.gz
77f0feb2 17# Source0-md5: b995941365f7ca6703d75110d908badc
cf21eb9c 18URL: http://search.cpan.org/dist/IO-Async/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl(Async::MergePoint)
23BuildRequires: perl(Socket::GetAddrInfo) >= 0.08
24BuildRequires: perl(Test::Refcount)
25BuildRequires: perl-Heap >= 0.8
26BuildRequires: perl-Test-Exception
27%endif
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32This collection of modules allows programs to be written that perform
33asynchronous filehandle IO operations. A typical program using them
34would consist of a single subclass of IO::Async::Loop to act as a
35container o other objects, which perform the actual IO work required
36by the program. As as IO handles, the loop also supports timers and
37signal handlers, and includes more higher-level functionallity built
38on top of these basic parts.
39
40Because there are a lot of classes in this collection, the following
41overview gives a brief description of each.
42
43The base class of all the event handling subclasses is
44IO::Async::Notifier. It does not perform any IO operations itself, but
45instead acts as a base class to build the specific IO functionallity
46upon. It can also coordinate a collection of other Notifiers contained
47within it, forming a tree structure.
48
49The following sections describe particular types of Notifier.
50
51# %description -l pl.UTF-8 # TODO
52
53%prep
54%setup -q -n %{pdir}-%{pnam}-%{version}
55
56%build
57%{__perl} Build.PL \
58 destdir=$RPM_BUILD_ROOT \
59 installdirs=vendor
60./Build
61
62%{?with_tests:./Build test}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66
67./Build install
68
69install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%files
76%defattr(644,root,root,755)
77%doc Changes README
78%{perl_vendorlib}/IO/*.pm
79%{perl_vendorlib}/IO/Async
80%{_mandir}/man3/*
81%{_examplesdir}/%{name}-%{version}
This page took 0.078152 seconds and 4 git commands to generate.