]> git.pld-linux.org Git - packages/perl-IO-Async.git/blame - perl-IO-Async.spec
- don't run resolver test
[packages/perl-IO-Async.git] / perl-IO-Async.spec
CommitLineData
cf21eb9c 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
cf21eb9c 5%define pdir IO
6%define pnam Async
7Summary: IO::Async - perform asynchronous filehandle IO and other operations
36a9cfed 8Summary(pl.UTF-8): IO::Async - asynchroniczne operacje we/wy na plikach i inne
cf21eb9c 9Name: perl-IO-Async
8d30a2ac
AO
10Version: 0.74
11Release: 1
cf21eb9c 12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
36a9cfed 15Source0: http://www.cpan.org/modules/by-module/IO/PEVANS/IO-Async-%{version}.tar.gz
8d30a2ac 16# Source0-md5: cf5f6a54c07f1d6f0ca484cac057bb6b
cf21eb9c 17URL: http://search.cpan.org/dist/IO-Async/
4a3a9180 18BuildRequires: perl-Module-Build
cf21eb9c 19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
36a9cfed
JB
22BuildRequires: perl-Async-MergePoint
23BuildRequires: perl-CPS
4a3a9180 24BuildRequires: perl-Future
36a9cfed
JB
25BuildRequires: perl-Heap >= 0.80
26BuildRequires: perl-Socket-GetAddrInfo >= 0.18
27BuildRequires: perl-Storable
4a3a9180 28BuildRequires: perl-Struct-Dumb
36a9cfed 29BuildRequires: perl-Time-HiRes
cf21eb9c 30BuildRequires: perl-Test-Exception
36a9cfed
JB
31BuildRequires: perl-Test-Fatal
32BuildRequires: perl-Test-Identity
33BuildRequires: perl-Test-Refcount
34BuildRequires: perl-Test-Warn
cf21eb9c 35%endif
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40This collection of modules allows programs to be written that perform
41asynchronous filehandle IO operations. A typical program using them
42would consist of a single subclass of IO::Async::Loop to act as a
36a9cfed
JB
43container of other objects, which perform the actual IO work required
44by the program. As well as IO handles, the loop also supports timers
45and signal handlers, and includes more higher-level functionallity
46built on top of these basic parts.
cf21eb9c 47
36a9cfed
JB
48%description -l pl.UTF-8
49Zestaw modułów umożliwiających pisanie programów wykonywanie
50asynchroncznych operacji we/wy na uchwytach plików. Typowy program
51wykonujący je składa się z pojedynczej podklasy IO::Async::Loop
52pełniącej rolę kontenera innych obiektów, wykonujących właściwe
53operacje we/wy wymagane przez program. Oprócz obsługi we/wy pętla
54obsługuje także stopery i sygnały, a także zawiera nieco funkcji
55wyższego poziomu stworzonych w oparciu o te podstawowe elementy.
cf21eb9c 56
57%prep
58%setup -q -n %{pdir}-%{pnam}-%{version}
59
ca37cd70
JR
60# No resolver / network on builders
61%{__rm} t/50resolver.t
62
cf21eb9c 63%build
64%{__perl} Build.PL \
65 destdir=$RPM_BUILD_ROOT \
66 installdirs=vendor
67./Build
68
69%{?with_tests:./Build test}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74./Build install
75
76install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%files
83%defattr(644,root,root,755)
84%doc Changes README
36a9cfed 85%{perl_vendorlib}/IO/Async.pm
cf21eb9c 86%{perl_vendorlib}/IO/Async
36a9cfed 87%{_mandir}/man3/IO::Async*.3pm*
cf21eb9c 88%{_examplesdir}/%{name}-%{version}
This page took 0.098186 seconds and 4 git commands to generate.