]> git.pld-linux.org Git - packages/perl-HTML-Clean.git/blobdiff - perl-HTML-Clean.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-HTML-Clean.git] / perl-HTML-Clean.spec
index c1807beba40fca417b0b347aba5fee389b54ab93..3c7a51459198bd76b535ba3296fff6379fcf7346 100644 (file)
@@ -1,53 +1,60 @@
-%include       /usr/lib/rpm/macros.perl
-Summary:       Perl HTML-Clean module
-Summary(pl):   Modu³ Perla HTML-Clean
-Name:          perl-HTML-Clean
-Version:       0.7
-Release:       3
-Copyright:     GPL
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
+%define                pdir    HTML
+%define                pnam    Clean
+Summary:       HTML::Clean - cleans up HTML code for web browsers, not humans
+Summary(pl.UTF-8):     HTML::Clean - czyści kod w HTML-u z punktu widzenia serwerów WWW
+Name:          perl-HTML-Clean
+Version:       0.8
+Release:       10
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Source:                ftp://ftp.perl.org/pub/CPAN/modules/by-module/HTML/HTML-Clean-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.005_03-14
-%requires_eq   perl
-Requires:      %{perl_sitearch}
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: ee562703b7700c7fd4173f355e83ec2c
+URL:           http://search.cpan.org/dist/HTML-Clean/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-The HTML::Clean module cleans and optimizes HTML documents.
+The HTML::Clean Perl module encapsulates a number of common techniques
+for minimizing the size of HTML files. You can typically save between
+10% and 50% of the size of a HTML file using these methods.
 
-%description -l pl
-Modu³ HTML::Clean czy¶ci i optymalizuje dokumenty HTML.
+%description -l pl.UTF-8
+Moduł Perla HTML::Clean zamyka w sobie kilka ogólnych technik
+minimalizacji rozmiaru plików HTML. Zazwyczaj pozwala on zaoszczędzić
+na rozmiarze pliku HTML od 10% do 50%.
 
 %prep
-%setup -q -n HTML-Clean-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT
-
-(
-  cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/HTML/Clean
-  sed -e "s#$RPM_BUILD_ROOT##" .packlist >.packlist.new
-  mv .packlist.new .packlist
-)
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man[13]/* \
-       README TODO Changes
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {README,TODO,Changes}.gz
+%doc Changes README TODO
 %attr(755,root,root) %{_bindir}/*
-
-%{perl_sitelib}/HTML/*.pm
-%{perl_sitearch}/auto/HTML/Clean
-
+%{perl_vendorlib}/HTML/*.pm
+%dir %{perl_vendorlib}/auto/HTML
+%dir %{perl_vendorlib}/auto/HTML/Clean
+%{perl_vendorlib}/auto/HTML/Clean/autosplit.ix
 %{_mandir}/man[13]/*
This page took 0.063282 seconds and 4 git commands to generate.