]> git.pld-linux.org Git - packages/perl-File-FcntlLock.git/blame - perl-File-FcntlLock.spec
- rebuild with perl 5.28.0
[packages/perl-File-FcntlLock.git] / perl-File-FcntlLock.spec
CommitLineData
91da37eb 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
a03f5484 4
91da37eb 5%define pdir File
6%define pnam FcntlLock
7%include /usr/lib/rpm/macros.perl
8Summary: File::FcntlLock - File locking with fcntl(2)
91da37eb 9Name: perl-File-FcntlLock
10Version: 0.14
4f9e2755 11Release: 10
91da37eb 12License: unknown
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
15# Source0-md5: 261aa44a9806181ae8fdf49bead7f828
a03f5484 16URL: http://search.cpan.org/dist/File-FcntlLock/
91da37eb 17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
91da37eb 19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22File locking in Perl is usually done using the flock() function.
23Unfortunately, this only allows locks on whole files and is often
24implemented in terms of flock(2), which has some shortcomings.
25
26Using this module file locking via fcntl(2) can be done (obviously,
27this restricts the use of the module to systems that have a fcntl(2)
28system call). Before a file (or parts of a file) can be locked, an
29object simulating a flock structure must be created and its properties
30set. Afterwards, by calling the lock() method a lock can be set or it
31can be determined if and which process currently holds the lock.
32
33To create a new object representing a flock structure call new():
34
35 $fs = new File::FcntlLock;
36
37You also can pass the new() method a set of key-value pairs to
38initialize the objects properties, e.g. use
39
91da37eb 40%prep
41%setup -q -n %{pdir}-%{pnam}-%{version}
42
43%build
44%{__perl} Makefile.PL \
45 INSTALLDIRS=vendor
46%{__make} \
47 CC="%{__cc}" \
48 OPTIMIZE="%{rpmcflags}"
49
50%{?with_tests:%{__make} test}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} pure_install \
56 DESTDIR=$RPM_BUILD_ROOT
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc Changes README
64%{perl_vendorarch}/File/*.pm
65%dir %{perl_vendorarch}/auto/File/FcntlLock
91da37eb 66%attr(755,root,root) %{perl_vendorarch}/auto/File/FcntlLock/*.so
67%{_mandir}/man3/*
This page took 0.127293 seconds and 4 git commands to generate.