]> git.pld-linux.org Git - packages/perl-Dist-CheckConflicts.git/blame - perl-Dist-CheckConflicts.spec
- updated to 0.06
[packages/perl-Dist-CheckConflicts.git] / perl-Dist-CheckConflicts.spec
CommitLineData
53b14b6e
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Dist
6%define pnam CheckConflicts
7%include /usr/lib/rpm/macros.perl
8Summary: Dist::CheckConflicts - declare version conflicts for your dist
9Summary(pl.UTF-8): Dist::CheckConflicts - deklarowanie wersji będących w konflikcie z pakietem
10Name: perl-Dist-CheckConflicts
621e62c2 11Version: 0.06
53b14b6e
JB
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
f2741171 16Source0: http://www.cpan.org/modules/by-authors/id/D/DO/DOY/%{pdir}-%{pnam}-%{version}.tar.gz
621e62c2 17# Source0-md5: 510193204fb24e24779e86b490b2d713
53b14b6e 18URL: http://search.cpan.org/dist/Dist-CheckConflicts/
621e62c2
JB
19BuildRequires: perl-ExtUtils-MakeMaker >= 6.30
20BuildRequires: perl-devel >= 1:5.8.1
53b14b6e
JB
21BuildRequires: rpm-perlprov >= 4.1-13
22%if %{with tests}
23BuildRequires: perl-List-MoreUtils >= 0.12
24BuildRequires: perl-Sub-Exporter
25BuildRequires: perl-Test-Fatal
26BuildRequires: perl-Test-Simple >= 0.88
27%endif
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32One shortcoming of the CPAN clients that currently exist is that they
33have no way of specifying conflicting downstream dependencies of
34modules. This module attempts to work around this issue by allowing
35you to specify conflicting versions of modules separately, and deal
36with them after the module is done installing.
37
38For instance, say you have a module Foo, and some other module Bar
39uses Foo. If Foo were to change its API in a non-backwards-compatible
40way, this would cause Bar to break until it is updated to use the new
41API. Foo can't just depend on the fixed version of Bar, because this
42will cause a circular dependency (because Bar is already depending on
43Foo), and this doesn't express intent properly anyway - Foo doesn't
44use Bar at all. The ideal solution would be for there to be a way to
45specify conflicting versions of modules in a way that would let CPAN
46clients update conflicting modules automatically after an existing
47module is upgraded, but until that happens, this module will allow
48users to do this manually.
49
50%description -l pl.UTF-8
51Jednym z obecnych niedociągnięć klientów CPAN jest to, że nie ma
52sposobu określenia zależności będących w konflikcie z modułami.
53Niniejszy moduł próbuje obejść ten problem pozwalając określić
54osobno wersje modułów będących w konflikcie i obsłużenie ich po
55zainstalowaniu modułu.
56
57Na przykład: mamy moduł Foo, a inny moduł Bar używa Foo. Jeśli Foo
58zmieni swoje API bez kompatybilności wstecznej, spowoduje to zepsucie
59Bar do jego uaktualnienia pod kątem nowego API. Foo nie może
60zwyczajnie zależeć od poprawionej wersji Bar, bo spowodowałoby to
61zależność cykliczną (ponieważ Bar już zależy od Foo) i nie wyraża
62właściwie intencji - Foo w ogóle nie używa Bar. Idealnym rozwiązaniem
63byłoby zapewnienie sposobu określania wersji modułów będących w
64konflikcie w sposób pozwalający klientom CPAN na automatyczne
65uaktualnienie będących w konflikcie modułów po uaktualnieniu
66istniejącego modułu - ale zanim to nastąpi, ten moduł pozwala
67użytkownikom uczynić to ręcznie.
68
69%prep
70%setup -q -n %{pdir}-%{pnam}-%{version}
71
72%build
73%{__perl} Makefile.PL \
74 INSTALLDIRS=vendor
75%{__make}
76
77%{?with_tests:%{__make} test}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%{__make} pure_install \
83 DESTDIR=$RPM_BUILD_ROOT
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
90%doc Changes README
3fe744a5 91%dir %{perl_vendorlib}/Dist
53b14b6e
JB
92%{perl_vendorlib}/Dist/CheckConflicts.pm
93%{_mandir}/man3/Dist::CheckConflicts.3pm*
This page took 0.094644 seconds and 4 git commands to generate.