]> git.pld-linux.org Git - packages/perl-Devel-REPL.git/blame - perl-Devel-REPL.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Devel-REPL.git] / perl-Devel-REPL.spec
CommitLineData
7486981a
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Devel
6%define pnam REPL
7486981a
JR
7Summary: Devel::REPL - a modern perl interactive shell
8Name: perl-Devel-REPL
9Version: 1.003012
10Release: 1
11License: GPL v1+ or Artistic
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
14# Source0-md5: bff993f2799b2e2cfbc89fbb74607106
15URL: http://search.cpan.org/dist/Devel-REPL/
16BuildRequires: perl-devel >= 1:5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18%if %{with tests}
19BuildRequires: perl-App-Nopaste
20BuildRequires: perl-B-Keywords
21BuildRequires: perl-Data-Dump-Streamer
22BuildRequires: perl-Data-Dumper-Concise
23BuildRequires: perl-File-HomeDir
24BuildRequires: perl-File-Next
25BuildRequires: perl-Lexical-Persistence
26BuildRequires: perl-Module-Refresh
27BuildRequires: perl-Moose >= 0.74
28BuildRequires: perl-MooseX-AttributeHelpers >= 0.16
29BuildRequires: perl-MooseX-Getopt >= 0.18
30BuildRequires: perl-MooseX-Object-Pluggable >= 0.0009
31BuildRequires: perl-PPI
32BuildRequires: perl-Sys-SigAction
33BuildRequires: perl-Task-Weaken
34BuildRequires: perl-namespace-clean
35%endif
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40This is an interactive shell for Perl, commonly known as a REPL -
41Read, Evaluate, Print, Loop. The shell provides for rapid development
42or testing of code without the need to create a temporary source code
43file.
44
45Through a plugin system, many features are available on demand. You
46can also tailor the environment through the use of profiles and run
47control files, for example to pre-load certain Perl modules when
48working on a particular project.
49
50%prep
51%setup -q -n %{pdir}-%{pnam}-%{version}
52
53%build
54%{__perl} Makefile.PL \
55 INSTALLDIRS=vendor
56%{__make}
57
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} pure_install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
73%defattr(644,root,root,755)
74%doc Changes README
75%attr(755,root,root) %{_bindir}/re.pl
76%{perl_vendorlib}/Devel/*.pm
77%{perl_vendorlib}/Devel/REPL
78%{_mandir}/man3/*
79%{_examplesdir}/%{name}-%{version}
This page took 0.059893 seconds and 4 git commands to generate.