]> git.pld-linux.org Git - packages/perl-DateTime-Locale.git/blame - perl-DateTime-Locale.spec
- tests BR: perl-File-Copy-Resursive
[packages/perl-DateTime-Locale.git] / perl-DateTime-Locale.spec
CommitLineData
4c84c59f
MP
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
dc9995d3 4
8fc450e6 5%define pdir DateTime
6%define pnam Locale
bf28c9b1 7Summary: DateTime::Locale - localization support for DateTime
e755f763 8Summary(pl.UTF-8): DateTime::Locale - wsparcie międzynarodowe dla DateTime
4c84c59f 9Name: perl-DateTime-Locale
c9d5299c 10Version: 1.32
53d3462f 11Release: 1
2f7c0621
JB
12# same as perl 5 + Unicode for CLDR data
13License: GPL v1+ or Artistic with Unicode parts
4c84c59f 14Group: Development/Languages/Perl
2f7c0621 15Source0: http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
c9d5299c 16# Source0-md5: 23ba33ef2d40f349f213ed00680f86aa
2f7c0621 17URL: https://metacpan.org/release/DateTime-Locale
1ddc8349 18BuildRequires: perl-Dist-CheckConflicts >= 0.02
c9d5299c 19BuildRequires: perl-File-ShareDir-Install >= 0.06
1ddc8349 20BuildRequires: perl-devel >= 1:5.8.4
4c84c59f 21BuildRequires: rpm-perlprov >= 4.1-13
93530688 22BuildRequires: rpmbuild(macros) >= 1.745
b16dc7ed 23%if %{with tests}
1ddc8349
JB
24BuildRequires: perl-CPAN-Meta-Check >= 0.011
25BuildRequires: perl-CPAN-Meta-Requirements
6d90f917 26BuildRequires: perl-File-Copy-Recursive
fc3e16da 27BuildRequires: perl-IPC-System-Simple
1ddc8349 28BuildRequires: perl-Params-ValidationCompiler >= 0.13
c9d5299c 29BuildRequires: perl-Path-Tiny
18d64bdc 30BuildRequires: perl-Scalar-List-Utils >= 1.45
1ddc8349 31BuildRequires: perl-Specio
fc3e16da 32BuildRequires: perl-Storable
fc3e16da 33BuildRequires: perl-Test-File-ShareDir
c9d5299c
JB
34BuildRequires: perl-Test-Simple >= 1.302015
35BuildRequires: perl-Test2-Suite
36BuildRequires: perl-Test2-Plugin-NoWarnings
1ddc8349 37BuildRequires: perl-namespace-autoclean >= 0.19
b16dc7ed 38%endif
dc9995d3 39BuildConflicts: perl-DateTime-Format-Strptime <= 1.1000
4c84c59f
MP
40BuildArch: noarch
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
d42927bd 43%define _noautoreq_perl DateTime::Locale.*
d6916c49 44
4c84c59f
MP
45%description
46This package contains DateTime::Locale, an factory for the various
906b1623 47locale subclasses. It also provides some functions for getting
4c84c59f
MP
48information on available locales.
49
8fd338af
JR
50%description -l pl.UTF-8
51Pakiet ten zawiera DateTime::Locale, źródło różnych klas związanych z
52umiędzynarodowieniem. Udostępnia również pewne funkcje służące do
53pobierania informacji o dostępnych locale.
bf28c9b1 54
4c84c59f
MP
55%prep
56%setup -q -n %{pdir}-%{pnam}-%{version}
57
58%build
18d64bdc
AM
59%{__perl} Makefile.PL \
60 INSTALLDIRS=vendor
61%{__make}
4c84c59f 62
18d64bdc 63%{?with_tests:%{__make} test}
4c84c59f
MP
64
65%install
66rm -rf $RPM_BUILD_ROOT
682d330a 67
18d64bdc
AM
68%{__make} install \
69 DESTDIR=$RPM_BUILD_ROOT
4c84c59f 70
d42927bd
JB
71%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/Locale/*.pod
72
fc3e16da
JB
73for f in $RPM_BUILD_ROOT%{perl_vendorlib}/auto/share/dist/DateTime-Locale/*.pl ; do
74 basename=$(basename $f .pl)
d42927bd
JB
75 lang=$(echo $basename | sed -e 's/^en-\(US-POSIX\|[0-9]\+\).*//; s/-VALENCIA//; s/-[0-9][0-9][0-9]//; s/-[A-Z][a-z][a-z][a-z]//; s/^\([a-z][a-z][a-z]\?\)-\([A-Z][A-Z]\)$/\1_\2/')
76 if [ -n "$lang" ]; then
77 langtag="%lang($lang) "
78 else
79 langtag=
80 fi
81 echo "${langtag}%{perl_vendorlib}/auto/share/dist/DateTime-Locale/${basename}.pl"
c9d5299c
JB
82 manname="$(echo "$basename" | tr - _)"
83 echo "${langtag}%{_mandir}/man3/DateTime::Locale::${manname}.3pm*"
fc3e16da
JB
84done > %{name}.lang
85
4c84c59f
MP
86%clean
87rm -rf $RPM_BUILD_ROOT
88
fc3e16da 89%files -f %{name}.lang
4c84c59f 90%defattr(644,root,root,755)
2f7c0621 91%doc Changes LICENSE.cldr
682d330a 92%{perl_vendorlib}/DateTime/Locale.pm
682d330a 93%{perl_vendorlib}/DateTime/Locale
fc3e16da 94%dir %{perl_vendorlib}/auto/share/dist/DateTime-Locale
c9d5299c
JB
95%{_mandir}/man3/DateTime::Locale.3pm*
96%{_mandir}/man3/DateTime::Locale::Base.3pm*
97%{_mandir}/man3/DateTime::Locale::Catalog.3pm*
98%{_mandir}/man3/DateTime::Locale::Data.3pm*
99%{_mandir}/man3/DateTime::Locale::FromData.3pm*
100%{_mandir}/man3/DateTime::Locale::Util.3pm*
101# generic man pages, without correspoding .pl files, so not caught by script
102%lang(ar) %{_mandir}/man3/DateTime::Locale::ar.3pm*
103%{_mandir}/man3/DateTime::Locale::en.3pm*
104%{_mandir}/man3/DateTime::Locale::en_CA.3pm*
105%{_mandir}/man3/DateTime::Locale::en_US.3pm*
106%lang(es) %{_mandir}/man3/DateTime::Locale::es.3pm*
107%lang(fr_FR) %{_mandir}/man3/DateTime::Locale::fr_FR.3pm*
108%lang(hi) %{_mandir}/man3/DateTime::Locale::hi.3pm*
109%lang(ja_JP) %{_mandir}/man3/DateTime::Locale::ja_JP.3pm*
110%lang(pt_BR) %{_mandir}/man3/DateTime::Locale::pt_BR.3pm*
111%lang(zh_CN) %{_mandir}/man3/DateTime::Locale::zh_Hans_CN.3pm*
112%lang(zh_TW) %{_mandir}/man3/DateTime::Locale::zh_Hant_TW.3pm*
This page took 0.094212 seconds and 4 git commands to generate.