]> git.pld-linux.org Git - packages/perl-Date-Manip.git/blobdiff - perl-Date-Manip.spec
- updated URL and macros
[packages/perl-Date-Manip.git] / perl-Date-Manip.spec
index e3b86108b3d4d9249c6cec826de5aa6d5f608fd4..f7df3ca0f47d639d03abf38567b8c9b4259d3dce 100644 (file)
@@ -1,25 +1,35 @@
-%include       /usr/lib/rpm/macros.perl
+#
+# Conditional build:
+%bcond_without tests   # unit tests
+#
 %define                pdir    Date
 %define                pnam    Manip
 Summary:       Date::Manip - date manipulation routines
 Summary(pl.UTF-8):     Date::Manip - procedury do operowania na datach
 Name:          perl-Date-Manip
-Version:       5.44
-Release:       2
+Version:       6.89
+Release:       1
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}%{pnam}-%{version}.tar.gz
-# Source0-md5: ebb1e17639fc4260b72690c1de2f5fdc
+Source0:       http://www.cpan.org/modules/by-module/Date/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: f9fe372c7abaf90e9da2ee7c3a4d32ff
+URL:           https://metacpan.org/dist/Date-Manip
+BuildRequires: perl-ExtUtils-MakeMaker >= 6.30
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
+%if %{with tests}
+BuildRequires: perl-Test-Inter
+BuildRequires: perl-YAML-Syck
+%endif
 Obsoletes:     perl-DateManip
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Perl module Date::Manip contains a set of routines designed to make
-any common date/time manipulation easy to do.  Operations such as
+any common date/time manipulation easy to do. Operations such as
 comparing two times, calculating a time a given amount of time from
 another, or parsing international times are all easily done.
 
@@ -31,24 +41,40 @@ zadanej ilości czasu od innego czasu, analiza czasów z podaną strefą
 czasową - wszystkie łatwo wykonać.
 
 %prep
-%setup -q -n %{pdir}%{pnam}-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Date/{Manip,Manip/*,Manip/Lang/*}.pod
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README TODO *.cnf
+%doc Changes LICENSE README.first
+%attr(755,root,root) %{_bindir}/dm_date
+%attr(755,root,root) %{_bindir}/dm_zdump
 %{perl_vendorlib}/Date/Manip.pm
-%{_mandir}/man3/*
+%dir %{perl_vendorlib}/Date/Manip
+%{perl_vendorlib}/Date/Manip/*.pm
+%dir %{perl_vendorlib}/Date/Manip/Lang
+%{perl_vendorlib}/Date/Manip/Lang/*.pm
+%dir %{perl_vendorlib}/Date/Manip/Offset
+%{perl_vendorlib}/Date/Manip/Offset/*.pm
+%dir %{perl_vendorlib}/Date/Manip/TZ
+%{perl_vendorlib}/Date/Manip/TZ/*.pm
+%{_mandir}/man1/dm_date.1*
+%{_mandir}/man1/dm_zdump.1*
+%{_mandir}/man3/Date::Manip*.3pm*
This page took 0.074783 seconds and 4 git commands to generate.