]> git.pld-linux.org Git - packages/perl-Data-Validate-Domain.git/blame - perl-Data-Validate-Domain.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Data-Validate-Domain.git] / perl-Data-Validate-Domain.spec
CommitLineData
1766cc9a
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Data
6%define pnam Validate-Domain
1766cc9a
ER
7Summary: Domain validation methods Perl module
8Name: perl-Data-Validate-Domain
9Version: 0.10
10Release: 1
11License: GPL+ or Artistic
12Group: Development/Libraries
13Source0: http://search.cpan.org/CPAN/authors/id/N/NE/NEELY/Data-Validate-Domain-%{version}.tar.gz
14# Source0-md5: 1331c0f47c024a83c610f8598490423a
15URL: http://search.cpan.org/dist/Data-Validate-Domain
16BuildRequires: rpm-perlprov >= 4.1-13
17%if %{with autodeps} || %{with tests}
18BuildRequires: perl(Exporter)
19BuildRequires: perl(ExtUtils::MakeMaker)
20BuildRequires: perl(Net::Domain::TLD) >= 1.62
21BuildRequires: perl(Test::More)
22%endif
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27This module collects domain validation routines to make input
28validation, and untainting easier and more readable.
29
30All functions return an untainted value if the test passes, and undef
31if it fails. This means that you should always check for a defined
32status explicitly. Don't assume the return will be true. (e.g.
33is_username('0'))
34
35The value to test is always the first (and often only) argument.
36
37%prep
38%setup -q -n Data-Validate-Domain-%{version}
39
40find lib -name "*.pm" -exec chmod -c a-x {} +
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make}
46
47%{?with_tests:%{__make} test}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51%{__make} pure_install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%doc Changes README
60%{perl_vendorlib}/Data/Validate/Domain.pm
61%{_mandir}/man3/Data::Validate::Domain.3pm*
This page took 0.059431 seconds and 4 git commands to generate.