]> git.pld-linux.org Git - packages/perl-Data-Denter.git/blame - perl-Data-Denter.spec
- tabs in preamble
[packages/perl-Data-Denter.git] / perl-Data-Denter.spec
CommitLineData
372afb6d 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
68327dcd 6%define pdir Data
7%define pnam Denter
8e5d6fb3 8Summary: Data::Denter - an (deprecated) alternative to Data::Dumper and Storable
96067c2a 9Summary(pl.UTF-8): Data::Denter - (porzucona) alternatywa dla Data::Dumper i Storable
372afb6d 10Name: perl-Data-Denter
11Version: 0.15
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 819e5c05fb61e90f4c1311286b080405
1266bbb2 18BuildRequires: perl-devel >= 1:5.8.0
372afb6d 19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
e2fde207 21# for perldiag.pod; should it be moved to perl-base?
22BuildRequires: perl-perldoc
372afb6d 23BuildRequires: perl-YAML
24%endif
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29The main problem with Data::Dumper (one of my all-time favorite
1266bbb2
JB
30modules) is that you have to use eval() to deserialize the data you've
31dumped. This is great if you can trust the data you're evaling, but
32horrible if you can't. A good alternative is Storable.pm. It can
372afb6d 33safely thaw your frozen data. But if you want to read/edit the frozen
34data, you're out of luck, because Storable uses a binary format. Even
1266bbb2
JB
35Data::Dumper's output can be a little cumbersome for larger data
36objects.
372afb6d 37
2cebab58
JR
38%description -l pl.UTF-8
39Głównym problemem klasy Data::Dumper (jednego z ulubionych modułów
40autora) jest to, że trzeba używać eval() aby dokonać deserializacji
41zrzuconych danych. Jest to wspaniałe, jeśli można zaufać danym, ale
42przerażające, jeśli nie możemy. Dobrą alternatywą jest moduł
43Storable.pm. Może on bezpiecznie roztopić zamrożone dane. Ale kiedy
44chcemy odczytać/zmodyfikować zamrożone dane, nie mamy szczęścia,
45ponieważ Storable używa binarnego formatu. Nawet format wyjścia modułu
46Data::Dumper może by nieco niewygodny dla większych obiektów danych.
372afb6d 47
48%prep
49%setup -q -n %{pdir}-%{pnam}-%{version}
50
51%build
52%{__perl} Makefile.PL \
53 INSTALLDIRS=vendor
54%{__make}
55
56%{?with_tests:%{__make} test}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc Changes README
1266bbb2 70%{perl_vendorlib}/Data/*.pm
372afb6d 71%{_mandir}/man3/*
This page took 0.076446 seconds and 4 git commands to generate.