]> git.pld-linux.org Git - packages/perl-Data-Compare.git/blobdiff - perl-Data-Compare.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Data-Compare.git] / perl-Data-Compare.spec
index e10eea2e7cefe587884c686cba0ee704b0dd552c..13ebfaa4a131b451fc4700c4172cfb0c3680afa8 100644 (file)
@@ -1,47 +1,64 @@
-%include       /usr/lib/rpm/macros.perl
-Summary:       Data-Compare perl module
-Summary(pl):   Modu³ perla Data-Compare
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
+%define                pdir    Data
+%define                pnam    Compare
+Summary:       Data::Compare - compare Perl data structures
+Summary(pl.UTF-8):     Data::Compare - porównywanie struktur danych w Perlu
 Name:          perl-Data-Compare
-Version:       0.02
-Release:       2
-License:       GPL
+# fill to four decimal digits to avoid epoch bumps after 1.2102
+%define        ver     1.25
+Version:       %{ver}00
+Release:       1
+Epoch:         1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Group(cs):     Vývojové prostøedky/Programovací jazyky/Perl
-Group(de):     Entwicklung/Sprachen/Perl
-Group(es):     Desarrollo/Lenguajes/Perl
-Group(fr):     Development/Langues/Perl
-Group(ja):     ³«È¯/¸À¸ì/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Group(pt):     Desenvolvimento/Linguagens/Perl
-Group(ru):     òÁÚÒÁÂÏÔËÁ/ñÚÙËÉ/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/Data/Data-Compare-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{ver}.tar.gz
+# Source0-md5: 6a397ab5833237f3ca05ed7277b19a7a
+URL:           http://search.cpan.org/dist/Data-Compare/
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: perl-devel >= 1:5.8.0
+%if %{with tests}
+BuildRequires: perl-File-Find-Rule >= 0.11
+BuildRequires: perl-Scalar-Properties
+BuildRequires: perl-perldoc
+%endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Data-Compare perl module - compare perl data structures.
+Data::Compare module compares two Perl data structures recursively.
 
-%description -l pl
-Modu³ perla Data-Compare s³u¿y do porównywania struktur danych.
+%description -l pl.UTF-8
+Moduł Data::Compare służy do rekurencyjnego porównywania dwóch
+struktur danych.
 
 %prep
-%setup -q -n Data-Compare-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{ver}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Data/Compare/Plugins.pod
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{perl_sitelib}/Data/Compare.pm
-%{_mandir}/man3/*
+%{perl_vendorlib}/Data/Compare.pm
+%dir %{perl_vendorlib}/Data/Compare
+%{perl_vendorlib}/Data/Compare/Plugins
+%{_mandir}/man3/Data::Compare.3pm*
+%{_mandir}/man3/Data::Compare::Plugins*.3pm*
This page took 0.103637 seconds and 4 git commands to generate.