]> git.pld-linux.org Git - packages/perl-DBI.git/blobdiff - perl-DBI.spec
- rebuild with perl 5.26
[packages/perl-DBI.git] / perl-DBI.spec
index fc0f128cf5935c3b39b1dd060c4d9128f8ce0973..db0f934d594a3b6ae82219df9c446073f6a7ce9d 100644 (file)
@@ -1,11 +1,11 @@
 #
 # Conditional build:
-%bcond_without autodeps        # don't BR packages needed only for resolving deps
+%bcond_with    coro            # don't package Coro transport
 %bcond_without tests           # perform "make test"
-#
-%include       /usr/lib/rpm/macros.perl
+
 %define                pdir    DBI
 %define                pnam    DBI
+%include       /usr/lib/rpm/macros.perl
 Summary:       DBI - database independent interface for Perl
 Summary(cs.UTF-8):     API pro přístup k databázím pro Perl
 Summary(da.UTF-8):     En database-API for Perl
@@ -23,25 +23,35 @@ Summary(ru.UTF-8):  Библиотека для доступа к базам да
 Summary(sv.UTF-8):     Ett databasåtkomst-API för Perl
 Summary(zh_CN.UTF-8):  Perl 的数据库访问 API。
 Name:          perl-DBI
-Version:       1.616
-Release:       1
+Version:       1.636
+Release:       2
 License:       GPL or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/DBI/TIMB/%{pnam}-%{version}.tar.gz
-# Source0-md5: 799313e54a693beb635b47918458f7c4
+Source0:       http://www.cpan.org/modules/by-module/DBI/%{pnam}-%{version}.tar.gz
+# Source0-md5: 60f291e5f015550dde71d1858dfe93ba
 URL:           http://search.cpan.org/dist/DBI/
-BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-ExtUtils-MakeMaker >= 6.48
+BuildRequires: perl-devel >= 1:5.8.1
 BuildRequires: rpm-perlprov >= 4.1-13
-%if %{with autodeps} || %{with tests}
+%if %{with tests}
 BuildRequires: perl-Net-Daemon
-BuildRequires: perl-PlRPC
+BuildRequires: perl-PlRPC >= 0.2001
+BuildRequires: perl-Test-Simple >= 0.90
 %endif
+Suggests:      perl-Clone >= 0.34
+Suggests:      perl-PlRPC >= 0.2001
+Suggests:      perl-SQL-Statement >= 1.402
 Obsoletes:     perl-DBI-FAQ
-Conflicts:     perl-DBD-CSV < 1:0.21
+Conflicts:     perl-DBD-Amazon < 0.10
+Conflicts:     perl-DBD-AnyData < 0.110
+Conflicts:     perl-DBD-CSV < 1:0.36
+Conflicts:     perl-DBD-Google < 0.51
+Conflicts:     perl-DBD-PO < 2.10
+Conflicts:     perl-DBD-RAM < 0.072
+Conflicts:     perl-SQL-Statement < 1.33
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl(DBD::<foo>)' 'perl(DBI)' 'perl(DBI::.*)' 'perl(DBD::File::.*)'
-%define                _noautoreqdep   'perl(UNIVERSAL)'
+%define                _noautoreq_perl DBD::<foo> DBI DBI::.* DBD::File::.*
 
 %description
 The DBI is a database access module for the Perl programming language.
@@ -154,6 +164,16 @@ Nie jest to oczywiście potrzebne dla sterowników DBI które same
 obsługują łączenie się ze zdalną bazą danych, ale oprócz nich są
 silniki, które nie oferują łączności sieciowej.
 
+%package Coro
+Summary:       Asynchronous DBD::Gofer stream transport using Coro
+Group:         Development/Languages/Perl
+Requires:      %{name} = %{version}-%{release}
+
+%description Coro
+This is an experimental asynchronous DBD::Gofer stream transport for
+DBI implemented on top of Coro. The BIG WIN from using Coro is that it
+enables the use of existing DBI frameworks like DBIx::Class.
+
 %package ProfileDumper-Apache
 Summary:       DBI::ProfileDumper::Apache - capture DBI profiling data from Apache/mod_perl
 Summary(pl.UTF-8):     DBI::ProfileDumper::Apache - przechwytywanie danych parametryzujących DBI z Apache/mod_perl
@@ -192,7 +212,6 @@ mv t/80proxy.t{,-needs-syslog}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -208,12 +227,16 @@ install -d $RPM_BUILD_ROOT{%{perl_vendorlib}/DBIx,%{perl_vendorarch}/{DBIx,auto/
 # already in doc
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBI/Changes.pod
 
+%if %{without coro}
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBD/Gofer/Transport/corostream.pm
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc Changes README
+%doc Changes README.md
 %attr(755,root,root) %{_bindir}/dbilogstrip
 %attr(755,root,root) %{_bindir}/dbiprof
 %attr(755,root,root) %{_bindir}/dbiproxy
@@ -234,7 +257,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{perl_vendorarch}/auto/DBIx
 %{perl_vendorarch}/auto/DBI/*.h
 %{perl_vendorarch}/auto/DBI/Driver.xst
-%{perl_vendorarch}/auto/DBI/DBI.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/DBI/DBI.so
 %{_mandir}/man1/dbilogstrip.1p*
 %{_mandir}/man1/dbiprof.1p*
@@ -249,6 +271,9 @@ rm -rf $RPM_BUILD_ROOT
 %exclude %{perl_vendorarch}/DBD/Proxy.pm
 %exclude %{perl_vendorarch}/DBI/ProfileDumper/Apache.pm
 %exclude %{perl_vendorarch}/DBI/ProxyServer.pm
+%if %{with coro}
+%exclude %{perl_vendorarch}/DBD/Gofer/Transport/corostream.pm
+%endif
 
 %files -n perl-DBD-Proxy
 %defattr(644,root,root,755)
@@ -257,6 +282,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/DBD::Proxy.3pm*
 %{_mandir}/man3/DBI::ProxyServer.3pm*
 
+%if %{with coro}
+%files Coro
+%defattr(644,root,root,755)
+%doc ex/corogofer.pl
+%{perl_vendorarch}/DBD/Gofer/Transport/corostream.pm
+%endif
+
 %files ProfileDumper-Apache
 %defattr(644,root,root,755)
 %dir %{perl_vendorarch}/DBI/ProfileDumper
This page took 0.089717 seconds and 4 git commands to generate.