]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-Random.git/blobdiff - perl-Crypt-OpenSSL-Random.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-OpenSSL-Random.git] / perl-Crypt-OpenSSL-Random.spec
index 722153fa5da4b30abd900ee6ff170ab82b39214d..562cdc3858b82ff9189fe2849f7a2c1a09b08eec 100644 (file)
@@ -1,44 +1,52 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
+%bcond_without tests   # Do not perform "make test"
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    Crypt
 %define                pnam    OpenSSL-Random
 Summary:       Crypt::OpenSSL::Random - accessing the OpenSSL pseudo-random number generator
-Summary(pl):   Crypt::OpenSSL::Random - dostêp do generatora liczb pseudolosowych z OpenSSL
+Summary(pl.UTF-8):     Crypt::OpenSSL::Random - dostęp do generatora liczb pseudolosowych z OpenSSL
 Name:          perl-Crypt-OpenSSL-Random
-Version:       0.03
-Release:       3
-License:       GPL
+Version:       0.15
+Release:       9
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: openssl-devel >= 0.9.7
-BuildRequires: perl-devel >= 5.6.1
-BuildRequires: rpm-perlprov >= 3.0.3-16
+Source0:       http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: bcde8d5a822c91376deda3c4f0c75fbe
+URL:           https://metacpan.org/dist/Crypt-OpenSSL-Random
+BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-Crypt-OpenSSL-Guess >= 0.11
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Crypt::OpenSSL::Random provides the ability to seed and query the
 OpenSSL library's pseudo-random number generator.
 
-%description -l pl
-Modu³ Crypt::OpenSSL::Random daje mo¿liwo¶æ zasilania oraz odpytywanie
+%description -l pl.UTF-8
+Moduł Crypt::OpenSSL::Random daje możliwość zasilania oraz odpytywanie
 generatora liczb pseudolosowych z biblioteki OpenSSL.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-%{__perl} Makefile.PL
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make} \
+       CC="%{__cc}" \
+       OPTIMIZE="%{rpmcflags}"
 
-%{!?_without_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -46,9 +54,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes
-%{perl_sitearch}/Crypt/OpenSSL/Random.pm
-%dir %{perl_sitearch}/auto/Crypt/OpenSSL/Random
-%{perl_sitearch}/auto/Crypt/OpenSSL/Random/*.bs
-%{perl_sitearch}/auto/Crypt/OpenSSL/Random/autosplit.ix
-%attr(755,root,root) %{perl_sitearch}/auto/Crypt/OpenSSL/Random/*.so
-%{_mandir}/man3/*
+%{perl_vendorarch}/Crypt/OpenSSL/Random.pm
+%dir %{perl_vendorarch}/auto/Crypt/OpenSSL/Random
+%attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/Random/Random.so
+%{_mandir}/man3/Crypt::OpenSSL::Random.3pm*
This page took 0.216265 seconds and 4 git commands to generate.