]> git.pld-linux.org Git - packages/perl-Crypt-DES.git/blobdiff - perl-Crypt-DES.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-DES.git] / perl-Crypt-DES.spec
index 16b179c780c7fb938a8ead4cb1854e93c679586e..7fcb8979c44367fb7c3ca6c772f3b011c1b8302e 100644 (file)
@@ -1,43 +1,56 @@
-%include       /usr/lib/rpm/macros.perl
-%define        pdir    Crypt
-%define        pnam    DES
-Summary:       Crypt-DES perl module
-Summary(pl):   Modu³ perla Crypt-DES
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
+%define                pdir    Crypt
+%define                pnam    DES
+Summary:       Crypt::DES - Perl DES encryption module
+Summary(pl.UTF-8):     Crypt::DES - moduł Perla dla szyfrowania DES
 Name:          perl-Crypt-DES
-Version:       2.03
-Release:       3
-License:       distributable
+Version:       2.07
+Release:       14
+License:       BSD-like (see COPYRIGHT)
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: e845d24cf383ca4a30a3380a2735feac
+URL:           https://metacpan.org/dist/Crypt-DES
+%{?with_tests:BuildRequires:   perl-Crypt-CBC}
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Crypt-DES - Perl interface to DES block cipher.
+Crypt::DES is Perl interface to DES block cipher.
 
-%description -l pl
-Crypt-DES - modu³ wspomagaj±cy algorytm DES.
+%description -l pl.UTF-8
+Moduł Perla Crypt::DES zawiera obsługę algorytmu szyfrowania DES.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make} \
+       CC="%{__cc}" \
+       OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{perl_sitearch}/Crypt/DES.pm
-%dir %{perl_sitearch}/auto/Crypt/DES
-%{perl_sitearch}/auto/Crypt/DES/DES.bs
-%attr(755,root,root) %{perl_sitearch}/auto/Crypt/DES/DES.so
-%{_mandir}/man3/*
+%doc COPYRIGHT README
+%{perl_vendorarch}/Crypt/DES.pm
+%dir %{perl_vendorarch}/auto/Crypt/DES
+%attr(755,root,root) %{perl_vendorarch}/auto/Crypt/DES/DES.so
+%{_mandir}/man3/Crypt::DES.3pm*
This page took 0.102888 seconds and 4 git commands to generate.