]> git.pld-linux.org Git - packages/perl-Crypt-DES.git/blobdiff - perl-Crypt-DES.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-DES.git] / perl-Crypt-DES.spec
index 791a39baad0b64c5f4632f53c2315b0cf228c704..7fcb8979c44367fb7c3ca6c772f3b011c1b8302e 100644 (file)
@@ -1,51 +1,48 @@
-%include       /usr/lib/rpm/macros.perl
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %define                pdir    Crypt
 %define                pnam    DES
-Summary:       Crypt::DES Perl module
-Summary(cs):   Modul Crypt::DES pro Perl
-Summary(da):   Perlmodul Crypt::DES
-Summary(de):   Crypt::DES Perl Modul
-Summary(es):   Módulo de Perl Crypt::DES
-Summary(fr):   Module Perl Crypt::DES
-Summary(it):   Modulo di Perl Crypt::DES
-Summary(ja):   Crypt::DES Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   Crypt::DES ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul Crypt::DES
-Summary(pl):   Modu³ Perla Crypt::DES
-Summary(pt):   Módulo de Perl Crypt::DES
-Summary(pt_BR):        Módulo Perl Crypt::DES
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl Crypt::DES
-Summary(sv):   Crypt::DES Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl Crypt::DES
-Summary(zh_CN):        Crypt::DES Perl Ä£¿é
+Summary:       Crypt::DES - Perl DES encryption module
+Summary(pl.UTF-8):     Crypt::DES - moduł Perla dla szyfrowania DES
 Name:          perl-Crypt-DES
-Version:       2.03
-Release:       5
-License:       distributable
+Version:       2.07
+Release:       14
+License:       BSD-like (see COPYRIGHT)
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: e845d24cf383ca4a30a3380a2735feac
+URL:           https://metacpan.org/dist/Crypt-DES
+%{?with_tests:BuildRequires:   perl-Crypt-CBC}
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Crypt::DES - Perl interface to DES block cipher.
+Crypt::DES is Perl interface to DES block cipher.
 
-%description -l pl
-Crypt::DES - modu³ obs³uguj±cy algorytm szyfrowania DES.
+%description -l pl.UTF-8
+Moduł Perla Crypt::DES zawiera obsługę algorytmu szyfrowania DES.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
 %{__perl} Makefile.PL \
-       INSTALLDIRS=vendor 
-%{__make} OPTIMIZE="%{rpmcflags}"
+       INSTALLDIRS=vendor
+%{__make} \
+       CC="%{__cc}" \
+       OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -55,6 +52,5 @@ rm -rf $RPM_BUILD_ROOT
 %doc COPYRIGHT README
 %{perl_vendorarch}/Crypt/DES.pm
 %dir %{perl_vendorarch}/auto/Crypt/DES
-%{perl_vendorarch}/auto/Crypt/DES/DES.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/DES/DES.so
-%{_mandir}/man3/*
+%{_mandir}/man3/Crypt::DES.3pm*
This page took 0.083941 seconds and 4 git commands to generate.