]> git.pld-linux.org Git - packages/perl-Class-Refresh.git/blame - perl-Class-Refresh.spec
- adapter, remove weird test
[packages/perl-Class-Refresh.git] / perl-Class-Refresh.spec
CommitLineData
6e09e84d
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Class
6%define pnam Refresh
7%include /usr/lib/rpm/macros.perl
8Summary: Class::Refresh - refresh your classes during runtime
6e09e84d
JR
9Name: perl-Class-Refresh
10Version: 0.07
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 12d9332777c7654368010548386aa2d9
17URL: http://search.cpan.org/dist/Class-Refresh/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl(Class::Unload)
22BuildRequires: perl(Devel::OverrideGlobalRequire)
23BuildRequires: perl-Class-Load
6e09e84d
JR
24BuildRequires: perl-Test-Fatal
25BuildRequires: perl-Test-Requires
e65b4487 26BuildRequires: perl-Try-Tiny
6e09e84d
JR
27%endif
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
e65b4487
JR
32During development, it is fairly common to cycle between writing code
33and testing that code. Generally the testing happens within the test
34suite, but frequently it is more convenient to test things by hand
35when tracking down a bug, or when doing some exploratory coding. In
36many situations, however, this becomes inconvenient - for instance, in
37a REPL, or in a stateful web application, restarting from the
38beginning after every code change can get pretty tedious. This module
39allows you to reload your application classes on the fly, so that the
40code/test cycle becomes a lot easier.
6e09e84d
JR
41
42%prep
43%setup -q -n %{pdir}-%{pnam}-%{version}
44
e65b4487
JR
45# this does some temp dir hackery that fails on builders
46%{__rm} t/moose-metaclasses.t
47
6e09e84d
JR
48%build
49%{__perl} Makefile.PL \
50 INSTALLDIRS=vendor
51%{__make}
52
53%{?with_tests:%{__make} test}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} pure_install \
59 DESTDIR=$RPM_BUILD_ROOT
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc Changes README
67%{perl_vendorlib}/Class/Refresh.pm
68%{_mandir}/man3/*
This page took 0.172138 seconds and 4 git commands to generate.