]> git.pld-linux.org Git - packages/perl-CPAN.git/blame_incremental - perl-CPAN.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CPAN.git] / perl-CPAN.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir CPAN
6Summary: CPAN Perl module - query, download and build Perl modules from CPAN sites
7Summary(pl.UTF-8): Moduł Perla CPAN - odpytywanie, ściąganie i budowanie modułów Perla z serwisów CPAN
8Name: perl-CPAN
9Version: 2.26
10Release: 1
11# same as perl
12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{version}.tar.gz
15# Source0-md5: f8b88baa35bd6ae582d3dd9b6c5e4771
16URL: http://search.cpan.org/dist/CPAN/
17%if %{with tests}
18BuildRequires: perl-Test-Simple
19%endif
20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26The CPAN module is designed to automate the make and install of perl
27modules and extensions. It includes some searching capabilities and
28knows how to use Net::FTP or LWP (or lynx or an external FTP client)
29to fetch the raw data from the net.
30
31%description -l pl.UTF-8
32Moduł CPAN służy do automatyzacji procesu budowania i instalowania
33modułów i rozszerzeń Perla. Ma możliwość wyszukiwania i używania
34Net::FTP lub LWP (albo lynksa czy zewnętrznego klienta FTP) do
35ściągania danych z sieci.
36
37%prep
38%setup -q -n %{pdir}-%{version}
39
40%build
41%{__perl} Makefile.PL \
42 INSTALLDIRS=vendor
43%{__make}
44
45%{?with_tests:%{__make} test}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50%{__make} install \
51 DESTDIR=$RPM_BUILD_ROOT
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%doc Todo
59%attr(755,root,root) %{_bindir}/cpan
60%attr(755,root,root) %{_bindir}/cpan-mirrors
61%{perl_vendorlib}/*.pm
62%{perl_vendorlib}/App/Cpan.pm
63%dir %{perl_vendorlib}/CPAN
64%{perl_vendorlib}/CPAN/*.pm
65%dir %{perl_vendorlib}/CPAN/API
66%{perl_vendorlib}/CPAN/API/HOWTO.pod
67%dir %{perl_vendorlib}/CPAN/Exception
68%{perl_vendorlib}/CPAN/Exception/*.pm
69%dir %{perl_vendorlib}/CPAN/FTP
70%{perl_vendorlib}/CPAN/FTP/netrc.pm
71%dir %{perl_vendorlib}/CPAN/HTTP
72%{perl_vendorlib}/CPAN/HTTP/*.pm
73%dir %{perl_vendorlib}/CPAN/Kwalify
74%{perl_vendorlib}/CPAN/Kwalify/distroprefs*
75%dir %{perl_vendorlib}/CPAN/LWP
76%{perl_vendorlib}/CPAN/LWP/UserAgent.pm
77%dir %{perl_vendorlib}/CPAN/Plugin
78%{perl_vendorlib}/CPAN/Plugin/*.pm
79%{_mandir}/man1/*
80%{_mandir}/man3/App::Cpan.3pm*
81%{_mandir}/man3/C*
This page took 0.054472 seconds and 4 git commands to generate.