]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- new configuration files
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1Summary: OpenSSH free Secure Shell (SSH) implementation
2Name: openssh
3Version: 2.1.0
4Release: 1
5License: BSD
6Group: Applications/Networking
7Group(pl): Aplikacje/Sieciowe
8Source0: ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
9Source1: opensshd.conf
10Source2: openssh.conf
11Source3: opensshd.init
12Source4: opensshd.pamd
13Source5: openssh.sysconfig
14Source6: passwd.pamd
15Patch0: openssh-PAM_NEW_AUTHTOK.patch
16Patch1: openssh-libwrap.patch
17BuildRequires: openssl-devel >= 0.9.4-2
18BuildRequires: rpm >= 3.0.4
19BuildRequires: zlib-devel
20BuildRequires: pam-devel
21BuildRequires: XFree86-devel
22BuildRequires: gnome-libs-devel
23BuildRequires: gtk+-devel
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25Prereq: openssl >= 0.9.4-2
26Obsoletes: ssh < %{version}, ssh > %{version}
27
28%define _sysconfdir /etc/ssh
29
30%description
31Ssh (Secure Shell) a program for logging into a remote machine and for
32executing commands in a remote machine. It is intended to replace rlogin
33and rsh, and provide secure encrypted communications between two untrusted
34hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
35can also be forwarded over the secure channel.
36
37OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
38to date in terms of security and features, as well as removing all patented
39algorithms to seperate libraries (OpenSSL).
40
41This package includes the core files necessary for both the OpenSSH client
42and server. To make this package useful, you should also install
43openssh-clients, openssh-server, or both.
44
45%package clients
46Summary: OpenSSH Secure Shell protocol clients
47Requires: openssh
48Group: Applications/Networking
49Group(pl): Aplikacje/Sieciowe
50Obsoletes: ssh-clients < %{version}, ssh-clients > %{version}
51Requires: %{name} = %{version}
52
53%description clients
54Ssh (Secure Shell) a program for logging into a remote machine and for
55executing commands in a remote machine. It is intended to replace rlogin
56and rsh, and provide secure encrypted communications between two untrusted
57hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
58can also be forwarded over the secure channel.
59
60OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
61to date in terms of security and features, as well as removing all patented
62algorithms to seperate libraries (OpenSSL).
63
64This package includes the clients necessary to make encrypted connections
65to SSH servers.
66
67%package server
68Summary: OpenSSH Secure Shell protocol server (sshd)
69Requires: openssh chkconfig >= 0.9
70Group: Networking/Daemons
71Group(pl): Sieciowe/Serwery
72Obsoletes: ssh-server < %{version}, ssh-server > %{version}
73Requires: rc-scripts
74Requires: /bin/login
75Requires: util-linux
76Prereq: %{name} = %{version}
77
78%description server
79Ssh (Secure Shell) a program for logging into a remote machine and for
80executing commands in a remote machine. It is intended to replace rlogin
81and rsh, and provide secure encrypted communications between two untrusted
82hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
83can also be forwarded over the secure channel.
84
85OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
86to date in terms of security and features, as well as removing all patented
87algorithms to seperate libraries (OpenSSL).
88
89This package contains the secure shell daemon. The sshd is the server part
90of the secure shell protocol and allows ssh clients to connect to your
91host.
92
93%package gnome-askpass
94Summary: OpenSSH GNOME passphrase dialog
95Group: Applications/Networking
96Group(pl): Aplikacje/Sieciowe
97Requires: %{name} = %{version}
98Obsoletes: ssh-extras < %{version}, ssh-extras > %{version}
99Obsoletes: ssh-askpass < %{version}, ssh-askpass > %{version}
100Obsoletes: openssh-askpass < %{version}, openssh-askpass > %{version}
101
102%description gnome-askpass
103Ssh (Secure Shell) a program for logging into a remote machine and for
104executing commands in a remote machine. It is intended to replace rlogin
105and rsh, and provide secure encrypted communications between two untrusted
106hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
107can also be forwarded over the secure channel.
108
109OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
110to date in terms of security and features, as well as removing all patented
111algorithms to seperate libraries (OpenSSL).
112
113This package contains the GNOME passphrase dialog.
114
115%prep
116%setup -q
117%patch0 -p1
118%patch1 -p1
119
120%build
121autoconf
122%configure \
123 --with-gnome-askpass \
124 --with-tcp-wrappers \
125 --with-md5-passwords \
126 --with-ipaddr-display \
127 --enable-ipv6 \
128 --enable-log-auth
129
130# with ipv4-default sshd can't listen on IPv6 and IPv4 sockets
131# --with-ipv4-default \
132# broken options
133# --without-kerberos4 \
134# --without-afs \
135# --without-skey
136
137echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
138
139make
140cd contrib && gcc `gnome-config --cflags gnome gnomeui` \
141 gnome-ssh-askpass.c -o gnome-ssh-askpass \
142 `gnome-config --libs gnome gnomeui`
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security}}
148
149make install DESTDIR="$RPM_BUILD_ROOT"
150
151install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
152install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
153install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
154install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
155install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
156install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
157install -d $RPM_BUILD_ROOT%{_libexecdir}/ssh
158install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
159
160gzip -9nf ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
161 $RPM_BUILD_ROOT/%{_mandir}/man*/*
162
163touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%post server
169/sbin/chkconfig --add sshd
170if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
171 /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' 1>&2
172fi
173if [ -f /var/lock/subsys/sshd ]; then
174 /etc/rc.d/init.d/sshd restart 1>&2
175else
176 echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
177fi
178if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
179 echo "ssh" >> /etc/security/passwd.conf
180fi
181
182%preun server
183if [ "$1" = 0 ]; then
184 if [ -f /var/lock/subsys/sshd ]; then
185 /etc/rc.d/init.d/sshd stop 1>&2
186 fi
187 /sbin/chkconfig --del sshd
188fi
189
190%files
191%defattr(644,root,root,755)
192%doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
193%attr(755,root,root) %{_bindir}/ssh-keygen
194%{_mandir}/man1/ssh-keygen.1*
195%dir %{_sysconfdir}
196
197%files clients
198%defattr(644,root,root,755)
199# suid root ?
200#%attr(4755,root,root) %{_bindir}/ssh
201%attr(0755,root,root) %{_bindir}/ssh
202%attr(0755,root,root) %{_bindir}/ssh-agent
203%attr(0755,root,root) %{_bindir}/ssh-add
204#%attr(0755,root,root) %{_bindir}/slogin
205%attr(755,root,root) %{_bindir}/scp
206%{_mandir}/man1/scp.1*
207%{_mandir}/man1/ssh.1*
208%{_mandir}/man1/ssh-agent.1*
209%{_mandir}/man1/ssh-add.1*
210#%{_mandir}/man1/slogin.1
211%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
212
213%files server
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_sbindir}/sshd
216%{_mandir}/man8/sshd.8*
217%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
218%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
219%attr(754,root,root) /etc/rc.d/init.d/sshd
220%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
221%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
222
223%files gnome-askpass
224%defattr(644,root,root,755)
225%dir %{_libexecdir}/ssh
226%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.023312 seconds and 4 git commands to generate.