]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
disable perl, doesn't build
[packages/nginx.git] / nginx.spec
index 77b91af9091fc9887bd4346fba15799553e2a4b6..f10b96cf33f363589e27e98e821bc89b3f22876e 100644 (file)
@@ -1,11 +1,13 @@
 # TODO
 # - /etc/sysconfig/nginx file
 # - missing perl build/install requires
+# - mod_spdy build http://mailman.nginx.org/pipermail/nginx-devel/2012-June/002343.html patch from http://nginx.org/patches/attic/spdy/
+#   http://nginx.org/en/docs/http/ngx_http_spdy_module.html
 #
 # Conditional build for nginx:
 %bcond_without light           # don't build light version
 %bcond_without mail            # don't build imap/mail proxy
-%bcond_without perl            # don't build with perl module
+%bcond_with    perl            # don't build with perl module
 %bcond_without addition        # adds module
 %bcond_without dav             # WebDAV
 %bcond_without flv             # FLV stream
 %bcond_without ssl             # ssl support
 %bcond_with    http_browser    # header "User-agent" parser
 %bcond_without rtmp            # rtmp support
+%bcond_without auth_request    # auth_request module
 
-%define                rtmp_version    1.0.2
+%define                rtmp_version    1.1.3
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajnoĹ›ci
+# nginx lines:
+# - stable: production quality with stable API
+# - mainline: production quality but API can change
 Name:          nginx
-Version:       1.4.4
+Version:       1.6.2
 Release:       1
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: 5dfaba1cbeae9087f3949860a02caa9f
+# Source0-md5: d1b55031ae6e4bce37f8776b94d8b930
 Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source2:       proxy.conf
@@ -53,7 +59,7 @@ Source19:     %{name}-light.service
 Source20:      %{name}-perl.service
 Source21:      %{name}-mail.service
 Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}.tar.gz
-# Source101-md5:       989659b13382e4ee3649fcaa6573c08e
+# Source101-md5:       66ee2b74799e03a25a9e3aaadd874436
 Patch0:                nginx-no-Werror.patch
 URL:           http://nginx.net/
 BuildRequires: mailcap
@@ -320,6 +326,8 @@ cp -f configure auto/
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_auth_request:--with-http_auth_request_module} \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
@@ -382,10 +390,12 @@ mv -f objs/nginx contrib/nginx-mail
        %{?with_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_auth_request:--with-http_auth_request_module} \
        --without-http_browser_module \
        --without-mail_pop3_module \
        --without-mail_imap_module \
        --without-mail_smtp_module \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
@@ -420,6 +430,8 @@ mv -f objs/nginx contrib/nginx-light
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_auth_request:--with-http_auth_request_module} \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
This page took 0.267867 seconds and 4 git commands to generate.