]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
disable perl, doesn't build
[packages/nginx.git] / nginx.spec
index 4963a3997ab019e3b013bcfcd7a74520178856eb..f10b96cf33f363589e27e98e821bc89b3f22876e 100644 (file)
@@ -1,15 +1,17 @@
 # TODO
 # - /etc/sysconfig/nginx file
 # - missing perl build/install requires
-# - nginx should have own group (and work with it) or use http group ?
+# - mod_spdy build http://mailman.nginx.org/pipermail/nginx-devel/2012-June/002343.html patch from http://nginx.org/patches/attic/spdy/
+#   http://nginx.org/en/docs/http/ngx_http_spdy_module.html
 #
 # Conditional build for nginx:
 %bcond_without light           # don't build light version
 %bcond_without mail            # don't build imap/mail proxy
-%bcond_without perl            # don't build with perl module
+%bcond_with    perl            # don't build with perl module
 %bcond_without addition        # adds module
 %bcond_without dav             # WebDAV
 %bcond_without flv             # FLV stream
+%bcond_without ipv6            # build without ipv6 support
 %bcond_without sub             # ngx_http_sub_module
 %bcond_without poll            # poll
 %bcond_without realip          # real ip (behind proxy)
 %bcond_without status          # stats module
 %bcond_without ssl             # ssl support
 %bcond_with    http_browser    # header "User-agent" parser
-#
+%bcond_without rtmp            # rtmp support
+%bcond_without auth_request    # auth_request module
+
+%define                rtmp_version    1.1.3
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
+# nginx lines:
+# - stable: production quality with stable API
+# - mainline: production quality but API can change
 Name:          nginx
-Version:       0.5.33
-Release:       0.8
+Version:       1.6.2
+Release:       1
 License:       BSD-like
-Group:         Networking/Daemons
-Source0:       http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
-# Source0-md5: a78be74b4fd8e009545ef02488fcac86
-Source1:       http://www.nginx.eu/favicon.ico
+Group:         Networking/Daemons/HTTP
+Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
+# Source0-md5: d1b55031ae6e4bce37f8776b94d8b930
+Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
-Source2:       http://www.nginx.eu/download/proxy.conf
-# Source2-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
+Source2:       proxy.conf
 Source3:       %{name}.logrotate
 Source4:       %{name}.mime
 Source5:       %{name}-light.conf
@@ -47,34 +54,23 @@ Source14:   %{name}-standard.conf
 Source15:      %{name}-standard.monitrc
 Source16:      %{name}-standard.init
 Source17:      %{name}-mime.types.sh
-Patch0:                %{name}-config.patch
+Source18:      %{name}-standard.service
+Source19:      %{name}-light.service
+Source20:      %{name}-perl.service
+Source21:      %{name}-mail.service
+Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}.tar.gz
+# Source101-md5:       66ee2b74799e03a25a9e3aaadd874436
+Patch0:                nginx-no-Werror.patch
 URL:           http://nginx.net/
 BuildRequires: mailcap
 BuildRequires: openssl-devel
 BuildRequires: pcre-devel
 %{?with_perl:BuildRequires: perl-CGI}
 %{?with_perl:BuildRequires: perl-devel}
+%{?with_perl:BuildRequires: python}
 %{?with_perl:BuildRequires: rpm-perlprov}
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.644
 BuildRequires: zlib-devel
-Requires(post,preun):  /sbin/chkconfig
-Requires(postun):      /usr/sbin/groupdel
-Requires(postun):      /usr/sbin/userdel
-Requires(pre): /bin/id
-Requires(pre): /usr/bin/getgid
-Requires(pre): /usr/sbin/groupadd
-Requires(pre): /usr/sbin/useradd
-Requires:      nginx-daemon
-Requires:      openssl
-Requires:      pcre
-Requires:      rc-scripts >= 0.2.0
-Requires:      zlib
-Suggests:      nginx-standard
-Provides:      group(http)
-Provides:      group(nginx)
-Provides:      user(nginx)
-Provides:      webserver
-Conflicts:     logrotate < 3.7-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/%{name}
@@ -89,8 +85,6 @@ released the source code under a BSD-like license. Although still in
 beta, nginx is known for its stability, rich feature set, simple
 configuration, and low resource consumption.
 
-Common files for nginx daemon.
-
 %description -l pl.UTF-8
 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
@@ -100,96 +94,178 @@ opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
 w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
 prostej konfiguracji oraz małej "zasobożerności".
 
+%package common
+Summary:       nginx - common files
+Summary(pl.UTF-8):     nginx - pliki wspólne
+Group:         Networking/Daemons/HTTP
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires:      openssl
+Requires:      pcre
+Requires:      rc-scripts >= 0.2.0
+Requires:      systemd-units >= 38
+Requires:      zlib
+Provides:      group(http)
+Provides:      group(nginx)
+Provides:      user(nginx)
+Provides:      webserver
+Conflicts:     logrotate < 3.8.0
+Obsoletes:     %{name} < 1.4.1-4.1
+
+%description common
+Common files for the nginx daemon.
+
+%description common -l pl.UTF-8
 Niezbędne pliki dla nginx.
 
 %package light
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
-Requires(postun):      /usr/sbin/groupdel
-Requires(postun):      /usr/sbin/userdel
-Requires:      %{name} = %{version}-%{release}
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      %{name}-common = %{version}-%{release}
 Requires:      openssl
 Requires:      pcre
 Requires:      zlib
-Provides:      group(http)
-Provides:      group(nginx)
 Provides:      nginx-daemon
-Provides:      user(nginx)
 Provides:      webserver
 
 %description light
+nginx ("engine x") is a high-performance HTTP server and reverse
+proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
+Sysoev for Rambler.ru, Russia's second-most visited website, where it
+has been running in production for over two and a half years. Igor has
+released the source code under a BSD-like license. Although still in
+beta, nginx is known for its stability, rich feature set, simple
+configuration, and low resource consumption.
+
 The smallest, but also the fastest nginx edition. No additional
 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
 
 %description light -l pl.UTF-8
+nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
+a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
+na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
+odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
+opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
+w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
+prostej konfiguracji oraz małej "zasobożerności".
+
 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
 FLV oraz IMAP, POP3, SMTP proxy.
 
 %package perl
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
-Requires(postun):      /usr/sbin/groupdel
-Requires(postun):      /usr/sbin/userdel
-Requires:      %{name} = %{version}-%{release}
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      %{name}-common = %{version}-%{release}
 Requires:      openssl
-Provides:      group(http)
-Provides:      group(nginx)
 Provides:      nginx-daemon
-Provides:      user(nginx)
 Provides:      webserver
 
 %description perl
+nginx ("engine x") is a high-performance HTTP server and reverse
+proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
+Sysoev for Rambler.ru, Russia's second-most visited website, where it
+has been running in production for over two and a half years. Igor has
+released the source code under a BSD-like license. Although still in
+beta, nginx is known for its stability, rich feature set, simple
+configuration, and low resource consumption.
+
 nginx with Perl support. Mail modules not included.
 
 %description perl -l pl.UTF-8
+nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
+a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
+na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
+odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
+opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
+w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
+prostej konfiguracji oraz małej "zasobożerności".
+
 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
 
 %package mail
 Summary:       High perfomance IMAP, POP3, SMTP proxy server
 Summary(pl.UTF-8):     IMAP, POP3, SMTP proxy o wysokiej wydajności
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
-Requires(postun):      /usr/sbin/groupdel
-Requires(postun):      /usr/sbin/userdel
-Requires:      %{name} = %{version}-%{release}
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      %{name}-common = %{version}-%{release}
 Requires:      openssl
 Requires:      pcre
 Requires:      zlib
-Provides:      group(http)
-Provides:      group(nginx)
 Provides:      nginx-daemon
-Provides:      user(nginx)
-Provides:      webserver
 
 %description mail
+nginx ("engine x") is a high-performance HTTP server and reverse
+proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
+Sysoev for Rambler.ru, Russia's second-most visited website, where it
+has been running in production for over two and a half years. Igor has
+released the source code under a BSD-like license. Although still in
+beta, nginx is known for its stability, rich feature set, simple
+configuration, and low resource consumption.
+
 nginx with mail support. Only mail modules included.
 
 %description mail -l pl.UTF-8
+nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
+a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
+na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
+odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
+opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
+w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
+prostej konfiguracji oraz małej "zasobożerności".
+
 nginx ze wsparciem tylko dla modułów poczty.
 
 %package standard
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
-Requires(postun):      /usr/sbin/groupdel
-Requires(postun):      /usr/sbin/userdel
-Requires:      %{name} = %{version}-%{release}
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      %{name}-common = %{version}-%{release}
 Requires:      openssl
-Provides:      group(http)
-Provides:      group(nginx)
+Provides:      nginx
 Provides:      nginx-daemon
 Conflicts:     logrotate < 3.7-4
 
 %description standard
+nginx ("engine x") is a high-performance HTTP server and reverse
+proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
+Sysoev for Rambler.ru, Russia's second-most visited website, where it
+has been running in production for over two and a half years. Igor has
+released the source code under a BSD-like license. Although still in
+beta, nginx is known for its stability, rich feature set, simple
+configuration, and low resource consumption.
+
 This is standard nginx version, without Perl support and IMAP, POP3,
 SMTP proxy. 
 
 %description standard -l pl.UTF-8
+nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
+a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
+na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
+odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
+opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
+w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
+prostej konfiguracji oraz małej "zasobożerności".
+ginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
+a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
+na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
+odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
+opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
+w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
+prostej konfiguracji oraz małej "zasobożerności".
+
 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
 IMAP, POP3, SMTP.
 
@@ -198,7 +274,7 @@ Summary:    nginx support for monit
 Summary(pl.UTF-8):     Wsparcie nginx dla monit
 Group:         Applications/System
 URL:           http://nginx.eu/
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-common = %{version}-%{release}
 Requires:      monit
 
 %description -n monit-rc-nginx
@@ -208,9 +284,13 @@ monitrc file for monitoring nginx webserver.
 Plik monitrc do monitorowania serwera WWW nginx.
 
 %prep
-%setup -q
+%setup -q %{?with_rtmp:-a101}
 %patch0 -p0
 
+%if %{with rtmp}
+mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
+%endif
+
 # build mime.types.conf
 #sh %{SOURCE17} /etc/mime.types
 
@@ -236,6 +316,7 @@ cp -f configure auto/
        %{?with_addition:--with-http_addition_module} \
        %{?with_dav:--with-http_dav_module} \
        %{?with_flv:--with-http_flv_module} \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_sub:--with-http_sub_module} \
        %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
@@ -244,6 +325,9 @@ cp -f configure auto/
        %{?with_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
+       %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_auth_request:--with-http_auth_request_module} \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
@@ -272,6 +356,7 @@ mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
        --with-mail \
        --with-mail_ssl_module \
        --without-http \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_poll:--with-poll_module} \
        %{?with_rtsig:--with-rtsig_module} \
        %{?with_select:--with-select_module} \
@@ -297,16 +382,20 @@ mv -f objs/nginx contrib/nginx-mail
        --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
        --user=nginx \
        --group=nginx \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
        %{?with_rtsig:--with-rtsig_module} \
        %{?with_select:--with-select_module} \
        %{?with_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
+       %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_auth_request:--with-http_auth_request_module} \
        --without-http_browser_module \
        --without-mail_pop3_module \
        --without-mail_imap_module \
        --without-mail_smtp_module \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
@@ -331,6 +420,7 @@ mv -f objs/nginx contrib/nginx-light
        %{?with_addition:--with-http_addition_module} \
        %{?with_dav:--with-http_dav_module} \
        %{?with_flv:--with-http_flv_module} \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_sub:--with-http_sub_module} \
        %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
@@ -339,6 +429,9 @@ mv -f objs/nginx contrib/nginx-light
        %{?with_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
+       %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_auth_request:--with-http_auth_request_module} \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
@@ -356,10 +449,13 @@ install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
        $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
        $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
        $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
-       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
-       $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
+       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
+       $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
+       $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
 
 install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
+install conf/scgi_params $RPM_BUILD_ROOT%{_sysconfdir}/scgi.params
+install conf/uwsgi_params $RPM_BUILD_ROOT%{_sysconfdir}/uwsgi.params
 install conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
 install conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
 install conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
@@ -372,12 +468,15 @@ install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
 install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
 install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
 install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
+install %{SOURCE18} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-standard.service
 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
+ln -sf %{systemdunitdir}/%{name}-standard.service $RPM_BUILD_ROOT/etc/systemd/system/nginx.service
 
 %if %{with light}
 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
+install %{SOURCE19} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-light.service
 install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
 %endif
 
@@ -385,6 +484,7 @@ install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
 install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
+install %{SOURCE21} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-mail.service
 install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
 %endif
 
@@ -393,6 +493,7 @@ install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
 install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
 install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
+install %{SOURCE20} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-perl.service
 install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
 install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
 install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
@@ -405,7 +506,7 @@ rm -rf $RPM_BUILD_ROOT%{_prefix}/html
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%pre
+%pre common
 %groupadd -r -g 213 %{name}
 %groupadd -g 51 http
 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
@@ -421,8 +522,12 @@ for a in access.log error.log; do
        fi
 done
 /sbin/chkconfig --add %{name}-standard
+%systemd_post %{name}-standard.service
 %service %{name}-standard restart
-echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
+echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-standard.conf" as config.'
+if ! [ -L /etc/systemd/system/nginx.service ] ; then
+       ln -s %{systemdunitdir}/%{name}-standard.service /etc/systemd/system/nginx.service || :
+fi
 
 %post light
 for a in access.log error.log; do
@@ -434,8 +539,9 @@ for a in access.log error.log; do
        fi
 done
 /sbin/chkconfig --add %{name}-light
+%systemd_post %{name}-light.service
 %service %{name}-light restart
-echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" as config'
+echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-light.conf" as config'
 
 %post perl
 for a in access.log error.log; do
@@ -447,8 +553,9 @@ for a in access.log error.log; do
        fi
 done
 /sbin/chkconfig --add %{name}-perl
+%systemd_post %{name}-perl.service
 %service %{name}-perl restart
-echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" as config'
+echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-perl.conf" as config'
 
 %post mail
 for a in access.log error.log; do
@@ -460,40 +567,69 @@ for a in access.log error.log; do
        fi
 done
 /sbin/chkconfig --add %{name}-mail
+%systemd_post %{name}-mail.service
 %service %{name}-mail restart
-echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" as config'
+echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-mail.conf" as config'
 
 %preun standard
 if [ "$1" = "0" ];then
        %service %{name}-standard stop
        /sbin/chkconfig --del %{name}-standard
 fi
+%systemd_preun %{name}-standard.service
 
 %preun light
 if [ "$1" = "0" ]; then
        %service %{name}-light stop
        /sbin/chkconfig --del %{name}-light
 fi
+%systemd_preun %{name}-light.service
 
 %preun perl
 if [ "$1" = "0" ]; then
        %service %{name}-perl stop
        /sbin/chkconfig --del %{name}-perl
 fi
+%systemd_preun %{name}-perl.service
 
 %preun mail
 if [ "$1" = "0" ]; then
        %service %{name}-mail stop
        /sbin/chkconfig --del %{name}-mail
 fi
+%systemd_preun %{name}-mail.service
 
-%postun
+%postun common
 if [ "$1" = "0" ]; then
        %userremove %{name}
        %groupremove %{name}
 fi
 
-%files
+%postun standard
+%systemd_reload
+
+%postun light
+%systemd_reload
+
+%postun perl
+%systemd_reload
+
+%postun mail
+%systemd_reload
+
+%triggerpostun -- %{name}-standard < 1.4.1-4
+%systemd_trigger %{name}-standard.service
+
+%triggerpostun -- %{name}-light < 1.4.1-4
+%systemd_trigger %{name}-light.service
+
+%triggerpostun -- %{name}-perl < 1.4.1-4
+%systemd_trigger %{name}-perl.service
+
+%triggerpostun -- %{name}-mail < 1.4.1-4
+%systemd_trigger %{name}-mail.service
+
+%files common
 %defattr(644,root,root,755)
 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
 %doc %lang(ru) CHANGES.ru
@@ -506,14 +642,20 @@ fi
 # XXX: duplicates, don't use such glob here
 #%attr(640,root,root) %{_sysconfdir}/*[_-]*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi.params
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi.params
 %attr(640,root,root) %{_sysconfdir}/mime.types
 %attr(640,root,root) %{_sysconfdir}/koi-utf
 %attr(640,root,root) %{_sysconfdir}/koi-win
 %attr(640,root,root) %{_sysconfdir}/win-utf
-%attr(750,root,root) %dir /var/log/archive/%{name}
-%attr(750,%{name},logs) /var/log/%{name}
+%dir %{_sysconfdir}/webapps.d
+%dir %{_sysconfdir}/vhosts.d
+%attr(750,nginx,logs) %dir /var/log/archive/%{name}
+%attr(750,nginx,logs) /var/log/%{name}
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
+%ghost /etc/systemd/system/nginx.service
 
 %files standard
 %defattr(644,root,root,755)
@@ -521,6 +663,7 @@ fi
 %attr(770,root,%{name}) /var/cache/%{name}-standard
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
+%{systemdunitdir}/%{name}-standard.service
 
 %if %{with mail}
 %files mail
@@ -529,6 +672,7 @@ fi
 %attr(770,root,%{name}) /var/cache/%{name}-mail
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
+%{systemdunitdir}/%{name}-mail.service
 %endif
 
 %if %{with light}
@@ -538,6 +682,7 @@ fi
 %attr(770,root,%{name}) /var/cache/%{name}-light
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-light
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
+%{systemdunitdir}/%{name}-light.service
 %endif
 
 %if %{with perl}
@@ -551,6 +696,7 @@ fi
 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
 %{perl_vendorarch}/auto/%{name}/%{name}.bs
 %{perl_vendorarch}/%{name}.pm
+%{systemdunitdir}/%{name}-perl.service
 %endif
 
 %files -n monit-rc-nginx
This page took 0.327598 seconds and 4 git commands to generate.