]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
- rel 3; provide /etc/nginx/snippets dir for custom config chunks that are not includ...
[packages/nginx.git] / nginx.spec
index f88af09165cf6834bb34d5147ba56c3863f4e80e..e878939c058942ec514070b4d728d6f8f467d84d 100644 (file)
 %bcond_with    http_browser    # http browser module (header "User-agent" parser)
 %bcond_with    modsecurity     # modsecurity module
 %bcond_with    rtmp            # rtmp support
+%bcond_without vts             # virtual host traffic status module
 
 %ifarch x32
 %undefine      with_rtsig
 %endif
 
 %define                ssl_version     1.0.2
-%define                rtmp_version    1.1.11
+%define                rtmp_version    1.2.1
+%define                vts_version     0.1.18
 %define                modsecurity_version     2.9.2
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
@@ -41,12 +43,12 @@ Summary(pl.UTF-8):  Serwer HTTP i odwrotne proxy o wysokiej wydajności
 # - stable: production quality with stable API
 # - mainline: production quality but API can change
 Name:          nginx
-Version:       1.13.4
-Release:       1
+Version:       1.15.9
+Release:       3
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: 42a3ca70cd292a149ba4f60862599245
+# Source0-md5: 00dde20d4d2cc65bdaf8950a5bd3e14b
 Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source2:       proxy.conf
@@ -60,7 +62,9 @@ Source18:     %{name}.service
 Source22:      http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
 # Source22-md5:        4d9454efb19269c4288ae408ea438b76
 Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
-# Source101-md5:       a87ab77c4414f80d394d712cceb39016
+# Source101-md5:       639ac2b78103adaccbcfe484a92acf44
+Source102:     https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
+# Source102-md5:       409a10dbd85e0b807cc77eecec29a3b5
 Patch0:                %{name}-no-Werror.patch
 Patch1:                %{name}-modsecurity-xheaders.patch
 URL:           http://nginx.org/
@@ -117,6 +121,9 @@ Requires(pre):      /usr/sbin/useradd
 Requires:      rc-scripts >= 0.2.0
 Requires:      systemd-units >= 38
 Suggests:      vim-syntax-nginx
+Obsoletes:     nginx-common < 1.13.3
+Obsoletes:     nginx-light < 1.13.3
+Obsoletes:     nginx-standard < 1.13.3
 Conflicts:     rpm < 4.4.2-0.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -250,7 +257,7 @@ monitrc file for monitoring nginx webserver.
 Plik monitrc do monitorowania serwera WWW nginx.
 
 %prep
-%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
+%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102}
 %patch0 -p0
 %{?with_modsecurity:%patch1 -p0}
 
@@ -258,6 +265,10 @@ Plik monitrc do monitorowania serwera WWW nginx.
 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
 %endif
 
+%if %{with vts}
+mv nginx-module-vts-%{vts_version} nginx-vts-module
+%endif
+
 # build mime.types.conf
 #sh %{SOURCE17} /etc/mime.types
 
@@ -278,6 +289,7 @@ cp -f configure auto/
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
        --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
+       --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
        --user=nginx \
        --group=nginx \
        %{?with_select:--with-select_module} \
@@ -309,6 +321,7 @@ cp -f configure auto/
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_vts:--add-module=./nginx-vts-module} \
        %{?with_auth_request:--with-http_auth_request_module} \
        %{?with_threads:--with-threads} \
        %{?with_http2:--with-http_v2_module} \
@@ -338,6 +351,7 @@ install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
        $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
        $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
        $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
        $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
        $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
 
@@ -443,6 +457,7 @@ fi
 %dir %attr(750,root,nginx) %{_sysconfdir}
 %dir %{_sysconfdir}/conf.d
 %dir %{_sysconfdir}/modules.d
+%dir %{_sysconfdir}/snippets
 %dir %{_sysconfdir}/vhosts.d
 %dir %{_sysconfdir}/webapps.d
 %attr(640,root,root) %{_sysconfdir}/mime.types
This page took 0.049277 seconds and 4 git commands to generate.