]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
Version: 1.6.0
[packages/nginx.git] / nginx.spec
index b2fbf4d00bf66f18c29ecd83cfccaad66c0068cc..97207cdb58dbd1a543bd65c1e1f557e804ec4676 100644 (file)
@@ -1,6 +1,8 @@
 # TODO
 # - /etc/sysconfig/nginx file
 # - missing perl build/install requires
+# - mod_spdy build http://mailman.nginx.org/pipermail/nginx-devel/2012-June/002343.html patch from http://nginx.org/patches/attic/spdy/
+#   http://nginx.org/en/docs/http/ngx_http_spdy_module.html
 #
 # Conditional build for nginx:
 %bcond_without light           # don't build light version
 %bcond_with    http_browser    # header "User-agent" parser
 %bcond_without rtmp            # rtmp support
 
-%define                rtmp_version    1.0.2
+%define                rtmp_version    1.1.3
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajnoĹ›ci
+# nginx lines:
+# - stable: production quality with stable API
+# - mainline: production quality but API can change
 Name:          nginx
-Version:       1.4.1
-Release:       5
+Version:       1.6.0
+Release:       1
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: fea7dfab995545ce27fe4c49dc21a972
+# Source0-md5: 8efa354f1c3c2ccf434a50d3fbe82340
 Source1:       http://nginx.net/favicon.ico
-# Source1-md5: 14054e0d276e25545c9f801c91164f69
+# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source2:       proxy.conf
 Source3:       %{name}.logrotate
 Source4:       %{name}.mime
@@ -53,7 +58,7 @@ Source19:     %{name}-light.service
 Source20:      %{name}-perl.service
 Source21:      %{name}-mail.service
 Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}.tar.gz
-# Source101-md5:       989659b13382e4ee3649fcaa6573c08e
+# Source101-md5:       66ee2b74799e03a25a9e3aaadd874436
 Patch0:                nginx-no-Werror.patch
 URL:           http://nginx.net/
 BuildRequires: mailcap
@@ -320,6 +325,7 @@ cp -f configure auto/
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
@@ -386,6 +392,7 @@ mv -f objs/nginx contrib/nginx-mail
        --without-mail_pop3_module \
        --without-mail_imap_module \
        --without-mail_smtp_module \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
@@ -420,6 +427,7 @@ mv -f objs/nginx contrib/nginx-light
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       --with-http_secure_link_module \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
This page took 0.100965 seconds and 4 git commands to generate.