]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
- fix patching
[packages/nginx.git] / nginx.spec
index e540c0264175a8c6005fafc7568432cfbf779082..6fed3bbe5850d617e148f31465e505b4b15c9a91 100644 (file)
@@ -10,6 +10,7 @@
 %bcond_without addition        # adds module
 %bcond_without dav             # WebDAV
 %bcond_without flv             # FLV stream
+%bcond_without ipv6            # build without ipv6 support
 %bcond_without sub             # ngx_http_sub_module
 %bcond_without poll            # poll
 %bcond_without realip          # real ip (behind proxy)
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajnoĹ›ci
 Name:          nginx
-Version:       0.7.65
-Release:       1
+Version:       1.2.4
+Release:       0.1
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
-Source0:       http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
-# Source0-md5: abc4f76af450eedeb063158bd963feaa
-Source1:       http://www.nginx.eu/favicon.ico
+Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
+# Source0-md5: a7c9a515f632c8cbb07ab67392208088
+Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
-Source2:       http://www.nginx.eu/download/proxy.conf
-# Source2-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
+Source2:       proxy.conf
 Source3:       %{name}.logrotate
 Source4:       %{name}.mime
 Source5:       %{name}-light.conf
@@ -47,6 +47,7 @@ Source14:     %{name}-standard.conf
 Source15:      %{name}-standard.monitrc
 Source16:      %{name}-standard.init
 Source17:      %{name}-mime.types.sh
+Patch0:                nginx-no-Werror.patch
 URL:           http://nginx.net/
 BuildRequires: mailcap
 BuildRequires: openssl-devel
@@ -64,7 +65,7 @@ Requires(pre):        /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires:      nginx-daemon
+#Requires:     nginx-daemon
 Requires:      openssl
 Requires:      pcre
 Requires:      rc-scripts >= 0.2.0
@@ -74,7 +75,7 @@ Provides:     group(http)
 Provides:      group(nginx)
 Provides:      user(nginx)
 Provides:      webserver
-Conflicts:     logrotate < 3.7-4
+Conflicts:     logrotate < 3.8.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/%{name}
@@ -209,6 +210,7 @@ Plik monitrc do monitorowania serwera WWW nginx.
 
 %prep
 %setup -q
+%patch0 -p0
 
 # build mime.types.conf
 #sh %{SOURCE17} /etc/mime.types
@@ -235,6 +237,7 @@ cp -f configure auto/
        %{?with_addition:--with-http_addition_module} \
        %{?with_dav:--with-http_dav_module} \
        %{?with_flv:--with-http_flv_module} \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_sub:--with-http_sub_module} \
        %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
@@ -271,6 +274,7 @@ mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
        --with-mail \
        --with-mail_ssl_module \
        --without-http \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_poll:--with-poll_module} \
        %{?with_rtsig:--with-rtsig_module} \
        %{?with_select:--with-select_module} \
@@ -296,6 +300,7 @@ mv -f objs/nginx contrib/nginx-mail
        --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
        --user=nginx \
        --group=nginx \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
        %{?with_rtsig:--with-rtsig_module} \
@@ -330,6 +335,7 @@ mv -f objs/nginx contrib/nginx-light
        %{?with_addition:--with-http_addition_module} \
        %{?with_dav:--with-http_dav_module} \
        %{?with_flv:--with-http_flv_module} \
+       %{?with_ipv6:--with-ipv6} \
        %{?with_sub:--with-http_sub_module} \
        %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
@@ -510,8 +516,8 @@ fi
 %attr(640,root,root) %{_sysconfdir}/koi-utf
 %attr(640,root,root) %{_sysconfdir}/koi-win
 %attr(640,root,root) %{_sysconfdir}/win-utf
-%attr(750,root,root) %dir /var/log/archive/%{name}
-%attr(750,%{name},logs) /var/log/%{name}
+%attr(750,nginx,logs) %dir /var/log/archive/%{name}
+%attr(750,nginx,logs) /var/log/%{name}
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
 
This page took 0.132729 seconds and 4 git commands to generate.