]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
- up to 1.0.10
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
6de999a5 4# - nginx should have own group (and work with it) or use http group ?
ee4f2132 5#
362f5ab2 6# Conditional build for nginx:
056acc18 7%bcond_without light # don't build light version
8%bcond_without mail # don't build imap/mail proxy
9%bcond_without perl # don't build with perl module
d0c0492d 10%bcond_without addition # adds module
11%bcond_without dav # WebDAV
12%bcond_without flv # FLV stream
3d4bad81 13%bcond_without ipv6 # build without ipv6 support
d6fc4b09 14%bcond_without sub # ngx_http_sub_module
d0c0492d 15%bcond_without poll # poll
16%bcond_without realip # real ip (behind proxy)
17%bcond_without rtsig # rtsig
18%bcond_without select # select
19%bcond_without status # stats module
20%bcond_without ssl # ssl support
056acc18 21%bcond_with http_browser # header "User-agent" parser
362f5ab2 22#
8e1389c7 23Summary: High perfomance HTTP and reverse proxy server
185313bb 24Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
f9e65082 25Name: nginx
9f9bba57 26Version: 1.0.10
fa3636be 27Release: 1
51ef519b 28License: BSD-like
cbf76340 29Group: Networking/Daemons/HTTP
06e274b9 30Source0: http://nginx.org/download/%{name}-%{version}.tar.gz
9f9bba57 31# Source0-md5: 930b297b00fa1018fb0a1dd3e6b7e17e
06e274b9 32Source1: http://nginx.net/favicon.ico
226bcc40 33# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
06e274b9 34Source2: proxy.conf
226bcc40 35Source3: %{name}.logrotate
36Source4: %{name}.mime
37Source5: %{name}-light.conf
38Source6: %{name}-light.monitrc
0da077af 39Source7: %{name}-light.init
40Source8: %{name}-mail.conf
41Source9: %{name}-mail.monitrc
42Source10: %{name}-mail.init
43Source11: %{name}-perl.conf
44Source12: %{name}-perl.monitrc
45Source13: %{name}-perl.init
46Source14: %{name}-standard.conf
47Source15: %{name}-standard.monitrc
7d80c773 48Source16: %{name}-standard.init
49Source17: %{name}-mime.types.sh
51ef519b 50URL: http://nginx.net/
dfef7372 51BuildRequires: mailcap
f9e65082 52BuildRequires: openssl-devel
f1fc9780 53BuildRequires: pcre-devel
1c438d78 54%{?with_perl:BuildRequires: perl-CGI}
d0c0492d 55%{?with_perl:BuildRequires: perl-devel}
dd2388c2 56%{?with_perl:BuildRequires: python}
1c438d78 57%{?with_perl:BuildRequires: rpm-perlprov}
7d9b86c7 58BuildRequires: rpmbuild(macros) >= 1.268
f9e65082 59BuildRequires: zlib-devel
7d9b86c7
ER
60Requires(post,preun): /sbin/chkconfig
61Requires(postun): /usr/sbin/groupdel
62Requires(postun): /usr/sbin/userdel
63Requires(pre): /bin/id
64Requires(pre): /usr/bin/getgid
65Requires(pre): /usr/sbin/groupadd
66Requires(pre): /usr/sbin/useradd
774b2694 67#Requires: nginx-daemon
d0c0492d 68Requires: openssl
69Requires: pcre
aba2d783 70Requires: rc-scripts >= 0.2.0
d0c0492d 71Requires: zlib
1cf92547 72Suggests: nginx-standard
ee547c00 73Provides: group(http)
74Provides: group(nginx)
75Provides: user(nginx)
7ffe7917 76Provides: webserver
226bcc40 77Conflicts: logrotate < 3.7-4
f9e65082
ER
78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
362f5ab2 80%define _sysconfdir /etc/%{name}
81%define _nginxdir /home/services/%{name}
f9e65082
ER
82
83%description
57f21172 84nginx ("engine x") is a high-performance HTTP server and reverse
85proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
894ff1f7
ER
86Sysoev for Rambler.ru, Russia's second-most visited website, where it
87has been running in production for over two and a half years. Igor has
88released the source code under a BSD-like license. Although still in
57f21172 89beta, nginx is known for its stability, rich feature set, simple
894ff1f7 90configuration, and low resource consumption.
8e1389c7 91
57f21172 92Common files for nginx daemon.
85600569 93
390f5b88 94%description -l pl.UTF-8
57f21172 95nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
96a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
056acc18 97na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
98odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
99opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
98376457 100w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1dc54c84 101prostej konfiguracji oraz małej "zasobożerności".
2ee780b1 102
57f21172 103Niezbędne pliki dla nginx.
85600569 104
2ee780b1 105%package light
106Summary: High perfomance HTTP and reverse proxy server
7ad53968 107Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 108Group: Networking/Daemons/HTTP
85600569 109Requires(post,preun): /sbin/chkconfig
110Requires(postun): /usr/sbin/groupdel
111Requires(postun): /usr/sbin/userdel
b0fa7cc6 112Requires: %{name} = %{version}-%{release}
85600569 113Requires: openssl
114Requires: pcre
115Requires: zlib
2ee780b1 116Provides: group(http)
117Provides: group(nginx)
119e2f19 118Provides: nginx-daemon
2ee780b1 119Provides: user(nginx)
120Provides: webserver
121
122%description light
57f21172 123The smallest, but also the fastest nginx edition. No additional
7ad53968 124modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
2ee780b1 125
126%description light -l pl.UTF-8
57f21172 127Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
1cf92547 128FLV oraz IMAP, POP3, SMTP proxy.
2ee780b1 129
130%package perl
131Summary: High perfomance HTTP and reverse proxy server
7ad53968 132Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 133Group: Networking/Daemons/HTTP
85600569 134Requires(post,preun): /sbin/chkconfig
135Requires(postun): /usr/sbin/groupdel
136Requires(postun): /usr/sbin/userdel
b0fa7cc6 137Requires: %{name} = %{version}-%{release}
85600569 138Requires: openssl
2ee780b1 139Provides: group(http)
140Provides: group(nginx)
1cf92547 141Provides: nginx-daemon
2ee780b1 142Provides: user(nginx)
143Provides: webserver
144
145%description perl
57f21172 146nginx with Perl support. Mail modules not included.
2ee780b1 147
148%description perl -l pl.UTF-8
57f21172 149nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
2ee780b1 150
151%package mail
57f21172 152Summary: High perfomance IMAP, POP3, SMTP proxy server
153Summary(pl.UTF-8): IMAP, POP3, SMTP proxy o wysokiej wydajności
cbf76340 154Group: Networking/Daemons/HTTP
85600569 155Requires(post,preun): /sbin/chkconfig
156Requires(postun): /usr/sbin/groupdel
157Requires(postun): /usr/sbin/userdel
b0fa7cc6 158Requires: %{name} = %{version}-%{release}
85600569 159Requires: openssl
160Requires: pcre
161Requires: zlib
2ee780b1 162Provides: group(http)
163Provides: group(nginx)
1cf92547 164Provides: nginx-daemon
2ee780b1 165Provides: user(nginx)
166Provides: webserver
167
168%description mail
57f21172 169nginx with mail support. Only mail modules included.
2ee780b1 170
171%description mail -l pl.UTF-8
57f21172 172nginx ze wsparciem tylko dla modułów poczty.
2ee780b1 173
b0fa7cc6 174%package standard
57f21172 175Summary: High perfomance HTTP and reverse proxy server
4ca0234e 176Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 177Group: Networking/Daemons/HTTP
d6fc4b09 178Requires(post,preun): /sbin/chkconfig
179Requires(postun): /usr/sbin/groupdel
180Requires(postun): /usr/sbin/userdel
b0fa7cc6 181Requires: %{name} = %{version}-%{release}
6de999a5 182Requires: openssl
183Provides: group(http)
184Provides: group(nginx)
1cf92547 185Provides: nginx-daemon
d6fc4b09 186Conflicts: logrotate < 3.7-4
28a25161 187
b0fa7cc6 188%description standard
57f21172 189This is standard nginx version, without Perl support and IMAP, POP3,
1dc54c84 190SMTP proxy.
fccff804 191
b0fa7cc6 192%description standard -l pl.UTF-8
57f21172 193To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
1dc54c84 194IMAP, POP3, SMTP.
85600569 195
dd7459ac 196%package -n monit-rc-nginx
57f21172 197Summary: nginx support for monit
198Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 199Group: Applications/System
200URL: http://nginx.eu/
60b8f836 201Requires: %{name} = %{version}-%{release}
1cf92547 202Requires: monit
dd7459ac 203
204%description -n monit-rc-nginx
57f21172 205monitrc file for monitoring nginx webserver.
dd7459ac 206
207%description -n monit-rc-nginx -l pl.UTF-8
57f21172 208Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 209
f9e65082
ER
210%prep
211%setup -q
f9e65082 212
a8eaad11 213# build mime.types.conf
7d80c773 214#sh %{SOURCE17} /etc/mime.types
a8eaad11 215
f9e65082
ER
216%build
217# NB: not autoconf generated configure
056acc18 218cp -f configure auto/
219#
220%if %{with perl}
221./configure \
222 --prefix=%{_prefix} \
4e61eac8 223 --sbin-path=%{_sbindir}/%{name}-perl \
224 --conf-path=%{_sysconfdir}/%{name}-perl.conf \
225 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
226 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
227 --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
228 --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
056acc18 229 --user=nginx \
230 --group=nginx \
231 --with-http_perl_module \
2ee780b1 232 --without-mail_pop3_module \
233 --without-mail_imap_module \
234 --without-mail_smtp_module \
056acc18 235 %{?with_addition:--with-http_addition_module} \
236 %{?with_dav:--with-http_dav_module} \
237 %{?with_flv:--with-http_flv_module} \
3d4bad81 238 %{?with_ipv6:--with-ipv6} \
d6fc4b09 239 %{?with_sub:--with-http_sub_module} \
056acc18 240 %{?with_poll:--with-poll_module} \
241 %{?with_realip:--with-http_realip_module} \
242 %{?with_rtsig:--with-rtsig_module} \
243 %{?with_select:--with-select_module} \
244 %{?with_status:--with-http_stub_status_module} \
245 %{?with_ssl:--with-http_ssl_module} \
246 %{!?with_http_browser:--without-http_browser_module} \
4e61eac8 247 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
248 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
249 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
056acc18 250 --with-cc="%{__cc}" \
251 --with-cc-opt="%{rpmcflags}" \
252 --with-ld-opt="%{rpmldflags}"
253%{__make}
4e61eac8 254mv -f objs/nginx contrib/nginx-perl
d6fc4b09 255mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
256mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
257mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
056acc18 258%endif
259
260%if %{with mail}
056acc18 261./configure \
262 --prefix=%{_prefix} \
4e61eac8 263 --sbin-path=%{_sbindir}/%{name}-mail \
264 --conf-path=%{_sysconfdir}/%{name}-mail.conf \
265 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
266 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
267 --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
268 --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
056acc18 269 --user=nginx \
270 --group=nginx \
271 --with-imap \
272 --with-mail \
273 --with-mail_ssl_module \
d6fc4b09 274 --without-http \
129a70a2 275 %{?with_ipv6:--with-ipv6} \
056acc18 276 %{?with_poll:--with-poll_module} \
056acc18 277 %{?with_rtsig:--with-rtsig_module} \
278 %{?with_select:--with-select_module} \
4e61eac8 279 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
280 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
281 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
056acc18 282 --with-cc="%{__cc}" \
283 --with-cc-opt="%{rpmcflags}" \
284 --with-ld-opt="%{rpmldflags}" \
285 %{?debug:--with-debug}
286%{__make}
4e61eac8 287mv -f objs/nginx contrib/nginx-mail
056acc18 288%endif
289
290%if %{with light}
056acc18 291./configure \
292 --prefix=%{_prefix} \
4e61eac8 293 --sbin-path=%{_sbindir}/%{name}-light \
294 --conf-path=%{_sysconfdir}/%{name}-light.conf \
295 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
296 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
297 --pid-path=%{_localstatedir}/run/%{name}-light.pid \
298 --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
056acc18 299 --user=nginx \
300 --group=nginx \
129a70a2 301 %{?with_ipv6:--with-ipv6} \
056acc18 302 %{?with_poll:--with-poll_module} \
303 %{?with_realip:--with-http_realip_module} \
304 %{?with_rtsig:--with-rtsig_module} \
305 %{?with_select:--with-select_module} \
306 %{?with_status:--with-http_stub_status_module} \
307 %{?with_ssl:--with-http_ssl_module} \
308 --without-http_browser_module \
1a62642d 309 --without-mail_pop3_module \
310 --without-mail_imap_module \
311 --without-mail_smtp_module \
4e61eac8 312 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
313 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
314 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
056acc18 315 --with-cc="%{__cc}" \
316 --with-cc-opt="%{rpmcflags}" \
317 --with-ld-opt="%{rpmldflags}" \
318 %{?debug:--with-debug}
319%{__make}
4e61eac8 320mv -f objs/nginx contrib/nginx-light
056acc18 321%endif
322
f9e65082
ER
323./configure \
324 --prefix=%{_prefix} \
226bcc40 325 --sbin-path=%{_sbindir}/%{name}-standard \
f1686a52 326 --conf-path=%{_sysconfdir}/%{name}-standard.conf \
226bcc40 327 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
328 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
329 --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
330 --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
dfef7372
ER
331 --user=nginx \
332 --group=nginx \
d0c0492d 333 %{?with_addition:--with-http_addition_module} \
334 %{?with_dav:--with-http_dav_module} \
335 %{?with_flv:--with-http_flv_module} \
129a70a2 336 %{?with_ipv6:--with-ipv6} \
d6fc4b09 337 %{?with_sub:--with-http_sub_module} \
d0c0492d 338 %{?with_poll:--with-poll_module} \
339 %{?with_realip:--with-http_realip_module} \
362f5ab2 340 %{?with_rtsig:--with-rtsig_module} \
341 %{?with_select:--with-select_module} \
d0c0492d 342 %{?with_status:--with-http_stub_status_module} \
362f5ab2 343 %{?with_ssl:--with-http_ssl_module} \
ee4f2132 344 %{!?with_http_browser:--without-http_browser_module} \
226bcc40 345 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
346 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
347 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
f9e65082
ER
348 --with-cc="%{__cc}" \
349 --with-cc-opt="%{rpmcflags}" \
350 --with-ld-opt="%{rpmldflags}" \
351 %{?debug:--with-debug}
f9e65082
ER
352%{__make}
353
056acc18 354
f9e65082
ER
355%install
356rm -rf $RPM_BUILD_ROOT
362f5ab2 357install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
358 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 359 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
226bcc40 360 $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
361 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
28a25161 362 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
363 $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
f9e65082 364
7d80c773 365install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
57f21172 366install conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
367install conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
368install conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
cd728db7 369install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
370install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
226bcc40 371install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
372install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
373install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
374install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
0da077af 375install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
376install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
377install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
de0bfb9b 378install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
85600569 379
380%if %{with light}
226bcc40 381install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
382install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
0da077af 383install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
4e61eac8 384install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
85600569 385%endif
386
387%if %{with mail}
0da077af 388install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
389install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
390install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
4e61eac8 391install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
85600569 392%endif
393
394%if %{with perl}
395install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
0da077af 396install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
397install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
398install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
d6fc4b09 399install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
400install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
401install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
4e61eac8 402install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
85600569 403%endif
f9e65082
ER
404
405rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
406rm -rf $RPM_BUILD_ROOT%{_prefix}/html
407
408%clean
409rm -rf $RPM_BUILD_ROOT
410
b0fa7cc6 411%pre
a37373c3 412%groupadd -r -g 213 %{name}
362f5ab2 413%groupadd -g 51 http
a37373c3 414%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 415%addusertogroup %{name} http
f1fc9780 416
738166d2 417%post standard
418for a in access.log error.log; do
419 if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
98376457 420 umask 022
738166d2 421 touch /var/log/%{name}/nginx-standard_$a
1cf92547 422 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
738166d2 423 chmod 644 /var/log/%{name}/nginx-standard_$a
424 fi
425done
3d760264
ER
426/sbin/chkconfig --add %{name}-standard
427%service %{name}-standard restart
428echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
738166d2 429
430%post light
431for a in access.log error.log; do
432 if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
98376457 433 umask 022
738166d2 434 touch /var/log/%{name}/nginx-light_$a
435 chown nginx:nginx /var/log/%{name}/nginx-light_$a
436 chmod 644 /var/log/%{name}/nginx-light_$a
437 fi
438done
3d760264
ER
439/sbin/chkconfig --add %{name}-light
440%service %{name}-light restart
57f21172 441echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" as config'
738166d2 442
443%post perl
444for a in access.log error.log; do
445 if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
98376457 446 umask 022
738166d2 447 touch /var/log/%{name}/nginx-perl_$a
448 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
449 chmod 644 /var/log/%{name}/nginx-perl_$a
450 fi
451done
3d760264
ER
452/sbin/chkconfig --add %{name}-perl
453%service %{name}-perl restart
57f21172 454echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" as config'
738166d2 455
456%post mail
362f5ab2 457for a in access.log error.log; do
738166d2 458 if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
98376457 459 umask 022
738166d2 460 touch /var/log/%{name}/nginx-mail_$a
461 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
462 chmod 644 /var/log/%{name}/nginx-mail_$a
362f5ab2 463 fi
464done
3d760264
ER
465/sbin/chkconfig --add %{name}-mail
466%service %{name}-mail restart
57f21172 467echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" as config'
f9e65082 468
b0fa7cc6 469%preun standard
7d80c773 470if [ "$1" = "0" ];then
6eef4074 471 %service %{name}-standard stop
226bcc40 472 /sbin/chkconfig --del %{name}-standard
f9e65082 473fi
f9e65082 474
0663f9da 475%preun light
476if [ "$1" = "0" ]; then
6eef4074 477 %service %{name}-light stop
226bcc40 478 /sbin/chkconfig --del %{name}-light
0663f9da 479fi
480
481%preun perl
482if [ "$1" = "0" ]; then
6eef4074 483 %service %{name}-perl stop
226bcc40 484 /sbin/chkconfig --del %{name}-perl
0663f9da 485fi
486
487%preun mail
488if [ "$1" = "0" ]; then
6eef4074 489 %service %{name}-mail stop
226bcc40 490 /sbin/chkconfig --del %{name}-mail
0663f9da 491fi
492
b0fa7cc6 493%postun
f1fc9780 494if [ "$1" = "0" ]; then
7d9b86c7
ER
495 %userremove %{name}
496 %groupremove %{name}
f1fc9780 497fi
498
f9e65082
ER
499%files
500%defattr(644,root,root,755)
6f8318ed 501%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 502%doc %lang(ru) CHANGES.ru
f1fc9780 503%dir %attr(754,root,root) %{_sysconfdir}
164ab75d 504%dir %{_nginxdir}
505%dir %{_nginxdir}/cgi-bin
506%dir %{_nginxdir}/html
507%dir %{_nginxdir}/errors
28a25161 508%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
98376457 509# XXX: duplicates, don't use such glob here
57f21172 510#%attr(640,root,root) %{_sysconfdir}/*[_-]*
98376457 511%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
394dc7b0 512%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
f1fc9780 513%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 514%attr(640,root,root) %{_sysconfdir}/koi-utf
515%attr(640,root,root) %{_sysconfdir}/koi-win
516%attr(640,root,root) %{_sysconfdir}/win-utf
fb1687bb 517%attr(750,root,root) %dir /var/log/archive/%{name}
f1fc9780 518%attr(750,%{name},logs) /var/log/%{name}
475fecd1 519%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 520%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 521
b0fa7cc6 522%files standard
523%defattr(644,root,root,755)
de0bfb9b 524%attr(755,root,root) %{_sbindir}/%{name}-standard
1846cd14 525%attr(770,root,%{name}) /var/cache/%{name}-standard
0da077af 526%attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
4ddbebd7 527%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
b0fa7cc6 528
85600569 529%if %{with mail}
530%files mail
531%defattr(644,root,root,755)
4e61eac8 532%attr(755,root,root) %{_sbindir}/%{name}-mail
1846cd14 533%attr(770,root,%{name}) /var/cache/%{name}-mail
0da077af 534%attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
4ddbebd7 535%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
85600569 536%endif
537
538%if %{with light}
539%files light
540%defattr(644,root,root,755)
4e61eac8 541%attr(755,root,root) %{_sbindir}/%{name}-light
1846cd14 542%attr(770,root,%{name}) /var/cache/%{name}-light
0da077af 543%attr(754,root,root) /etc/rc.d/init.d/%{name}-light
4ddbebd7 544%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
85600569 545%endif
546
547%if %{with perl}
548%files perl
549%defattr(644,root,root,755)
4e61eac8 550%attr(755,root,root) %{_sbindir}/%{name}-perl
0da077af 551%attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
f7b57295 552%attr(770,root,%{name}) /var/cache/%{name}-perl
1846cd14 553%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
85600569 554%dir %{perl_vendorarch}/auto/%{name}
555%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457
JB
556%{perl_vendorarch}/auto/%{name}/%{name}.bs
557%{perl_vendorarch}/%{name}.pm
dd7459ac 558%endif
559
560%files -n monit-rc-nginx
561%defattr(644,root,root,755)
562%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
563%if %{with perl}
1846cd14 564%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
85600569 565%endif
dd7459ac 566%if %{with light}
567%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
568%endif
569%if %{with mail}
570%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
571%endif
This page took 0.904331 seconds and 4 git commands to generate.