]> git.pld-linux.org Git - packages/netdata.git/blame - netdata.spec
up to 1.3.0 (2016-08-28)
[packages/netdata.git] / netdata.spec
CommitLineData
dbcc502d
ER
1#
2# Conditional build:
d0fcaadc 3%bcond_without nfacct # build with nfacct plugin
dbcc502d 4
94cfc344 5Summary: Linux real time performance monitoring
dbcc502d 6Name: netdata
a0a202fb
ER
7Version: 1.3.0
8Release: 0.1
4f48df40 9License: GPL v3+
dbcc502d 10Group: Applications/System
94cfc344 11Source0: https://github.com/firehol/netdata/releases/download/v%{version}/%{name}-%{version}.tar.xz
a0a202fb 12# Source0-md5: f2854aa2e127a1c9f86366f17524c382
01f0b59e 13Source1: %{name}.conf
1aa35efd 14Source2: %{name}.init
ea1ae9aa 15Patch0: nodejs.patch
dbcc502d 16URL: http://netdata.firehol.org/
085a70e6
ER
17BuildRequires: autoconf
18BuildRequires: automake
65ecfdca 19%{?with_nfacct:BuildRequires: libmnl-devel}
dbcc502d 20%{?with_nfacct:BuildRequires: libnetfilter_acct-devel}
c5372cd5 21BuildRequires: libuuid-devel
085a70e6 22BuildRequires: pkgconfig
1aa35efd 23BuildRequires: rpmbuild(macros) >= 1.647
dbcc502d 24BuildRequires: zlib-devel
1229dd1c
ER
25Provides: group(netdata)
26Provides: user(netdata)
1aa35efd
ER
27Requires(post,preun): /sbin/chkconfig
28Requires(post,preun,postun): systemd-units >= 38
1229dd1c
ER
29Requires(postun): /usr/sbin/groupdel
30Requires(postun): /usr/sbin/userdel
31Requires(pre): /bin/id
32Requires(pre): /usr/bin/getgid
33Requires(pre): /usr/sbin/groupadd
34Requires(pre): /usr/sbin/useradd
1aa35efd 35Requires: rc-scripts
1aa35efd
ER
36Suggests: %{name}-charts
37Suggests: %{name}-nodejs
a0a202fb 38Suggests: %{name}-python
dbcc502d
ER
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
f241237d
ER
41%define _libexecdir %{_prefix}/lib
42
dbcc502d
ER
43%description
44netdata is the fastest way to visualize metrics. It is a resource
45efficient, highly optimized system for collecting and visualizing any
46type of realtime timeseries data, from CPU usage, disk activity, SQL
47queries, API calls, web site visitors, etc.
48
49netdata tries to visualize the truth of now, in its greatest detail,
50so that you can get insights of what is happening now and what just
51happened, on your systems and applications.
52
bd51d1ce
ER
53%package charts
54Summary: netdata charts plugin
55Group: Applications/System
56URL: https://github.com/firehol/netdata/wiki/General-Info---charts.d
57Requires: %{name} = %{version}-%{release}
58Requires: bash >= 4
59%if "%{_rpmversion}" >= "5"
60BuildArch: noarch
61%endif
62
63%description charts
64Charts.d is BaSH script that allows you to write simple scripts for
65collecting data.
66
67It has been designed so that the actual script that will do data
68collection will be permanently in memory, collecting data with as
69little overheads as possible (i.e. initialize once, repeatedly collect
70values with minimal overhead).
71
72Charts.d looks for scripts in charts.d. The scripts should have the
73filename suffix: .chart.sh.
74
f241237d
ER
75%package nodejs
76Summary: netdata node.js plugins
77Group: Applications/System
78URL: https://github.com/firehol/netdata/wiki/General-Info---node.d
79Requires: %{name} = %{version}-%{release}
f241237d
ER
80%if "%{_rpmversion}" >= "5"
81BuildArch: noarch
82%endif
83
84%description nodejs
85node.d.plugin is a netdata plugin that provides an abstraction layer
86to allow easy and quick development of data collectors in node.js. It
87also manages all its data collectors (placed in node.d) using a single
88instance of node, thus lowering the memory footprint of data
89collection.
90
a0a202fb
ER
91%package python
92Summary: netdata Python plugins
93Group: Applications/System
94URL: https://github.com/firehol/netdata/wiki/How-to-write-new-module
95Requires: %{name} = %{version}-%{release}
96%if "%{_rpmversion}" >= "5"
97BuildArch: noarch
98%endif
99
100%description python
101Netdata Python plugins.
102
dbcc502d
ER
103%prep
104%setup -q
ea1ae9aa 105%patch0 -p1
dbcc502d
ER
106
107%build
108%{__aclocal} -I m4
109%{__autoconf}
110%{__autoheader}
111%{__automake}
112%configure \
f241237d 113 --libdir=%{_libexecdir} \
dbcc502d
ER
114 --with-zlib \
115 --with-math \
116 %{__enable_disable nfacct plugin-nfacct} \
117 --with-user=netdata
118%{__make}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
124
a0a202fb
ER
125%{__rm} $RPM_BUILD_ROOT/var/{cache,lib,log}/netdata/.keep
126%{__rm} $RPM_BUILD_ROOT/var/lib/netdata/registry/.keep
1aa35efd 127
2f40a1c0 128install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{systemdunitdir},%{_localstatedir}/lib/%{name}/registry}
f241237d 129cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
1aa35efd 130install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
f5dc427f 131cp -p system/netdata.service $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
01f0b59e 132
1aa35efd
ER
133%clean
134rm -rf $RPM_BUILD_ROOT
135
dbcc502d 136%pre
1229dd1c
ER
137%groupadd -g 329 netdata
138%useradd -u 329 -g netdata -c netdata -s /sbin/nologin -d / netdata
139
dbcc502d 140%post
1aa35efd
ER
141/sbin/chkconfig --add netdata
142%service netdata restart
dbcc502d
ER
143%systemd_post netdata.service
144
145%preun
1aa35efd
ER
146if [ "$1" = "0" ]; then
147 %service -q netdata stop
148 /sbin/chkconfig --del netdata
149fi
dbcc502d
ER
150%systemd_preun netdata.service
151
152%postun
1aa35efd
ER
153if [ "$1" = "0" ]; then
154 %userremove netdata
155 %groupremove netdata
156fi
157%systemd_reload
dbcc502d
ER
158
159%files
160%defattr(644,root,root,755)
161%dir %{_sysconfdir}/%{name}
c8a7f904
ER
162%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/apps_groups.conf
163%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/netdata.conf
a0a202fb
ER
164%dir %{_sysconfdir}/%{name}/health.d
165%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/health.d/*.conf
1aa35efd 166%attr(754,root,root) /etc/rc.d/init.d/netdata
dbcc502d 167%attr(755,root,root) %{_sbindir}/%{name}
cf647efe 168%dir %{_datadir}/%{name}
5c048d80 169%dir %{_libexecdir}/%{name}
dbcc502d
ER
170%{systemdunitdir}/netdata.service
171%attr(755,netdata,netdata) %dir %{_localstatedir}/cache/%{name}
172%attr(755,netdata,netdata) %dir %{_localstatedir}/log/%{name}
2f40a1c0
ER
173%attr(755,netdata,netdata) %dir %{_localstatedir}/lib/%{name}
174%attr(755,netdata,netdata) %dir %{_localstatedir}/lib/%{name}/registry
5c048d80
ER
175
176%defattr(-,root,root,-)
5c048d80 177%{_libexecdir}/%{name}/plugins.d
bd51d1ce 178# subpackages
9c1cee53 179%exclude %{_libexecdir}/%{name}/plugins.d/node.d.plugin
bd51d1ce
ER
180%exclude %{_libexecdir}/%{name}/plugins.d/charts.d*
181
cf647efe
ER
182%defattr(-,root,netdata,-)
183%{_datadir}/%{name}/web
184
bd51d1ce
ER
185%files charts
186%defattr(644,root,root,755)
c8a7f904 187%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/charts.d.conf
bd51d1ce
ER
188%attr(755,root,root) %{_libexecdir}/%{name}/plugins.d/charts.d*
189%dir %{_libexecdir}/%{name}/charts.d
190%{_libexecdir}/%{name}/charts.d/README.md
191%attr(755,root,root) %{_libexecdir}/%{name}/charts.d/*.chart.sh
f241237d
ER
192
193%files nodejs
194%defattr(644,root,root,755)
9c1cee53 195%attr(755,root,root) %{_libexecdir}/%{name}/plugins.d/node.d.plugin
f241237d
ER
196%dir %{_libexecdir}/%{name}/node.d
197%{_libexecdir}/%{name}/node.d/README.md
198%{_libexecdir}/%{name}/node.d/node_modules
199%attr(755,root,root) %{_libexecdir}/%{name}/node.d/*.node.js
a0a202fb
ER
200
201%files python
202%defattr(644,root,root,755)
203%dir %{_sysconfdir}/%{name}/python.d
204%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/python.d.conf
205%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/python.d/*.conf
206%dir %{_libexecdir}/%{name}/python.d
207%{_libexecdir}/%{name}/python.d/README.md
208%attr(755,root,root) %{_libexecdir}/%{name}/python.d/*.chart.py
209
210# XXX system packages
211%{_libexecdir}/%{name}/python.d/python-modules-installer.sh
212%dir %{_libexecdir}/%{name}/python.d/python_modules
213%{_libexecdir}/%{name}/python.d/python_modules/*.py
214%{_libexecdir}/%{name}/python.d/python_modules/pyyaml2
215%{_libexecdir}/%{name}/python.d/python_modules/pyyaml3
This page took 0.087213 seconds and 4 git commands to generate.