]> git.pld-linux.org Git - packages/net-snmp.git/blobdiff - net-snmp.spec
- error about /proc/partitions also only once
[packages/net-snmp.git] / net-snmp.spec
index 7d3b75cef78de66a4a43c91e83aab1eb2da7133d..e6c300200fb74932fa5c1ee8be80e21b91b68a11 100644 (file)
@@ -1,6 +1,4 @@
 # TODO
-# - package or remove:
-#   %{_datadir}/snmp/snmp_perl.pl
 # - make noarch -n mibs-net-snmp package (need separate .spec then)
 # - FHS: #define NETSNMP_AGENTX_SOCKET "/var/agentx/master"
 # - php-snmp (and likely other bindings) use only %{_libdir}/libnetsnmp.so.*, move other libs back to main (daemon) package?
@@ -18,7 +16,7 @@
 %undefine      with_lm_sensors
 %endif
 
-%define                so_version      25
+%define                so_version      30
 %include       /usr/lib/rpm/macros.perl
 Summary:       A collection of SNMP protocol tools
 Summary(es.UTF-8):     Agente SNMP de la UCD
@@ -27,12 +25,12 @@ Summary(pt_BR.UTF-8):       Agente SNMP da UCD
 Summary(ru.UTF-8):     Набор утилит для протокола SNMP от UC-Davis
 Summary(uk.UTF-8):     Набір утиліт для протоколу SNMP від UC-Davis
 Name:          net-snmp
-Version:       5.6.1.1
-Release:       2
+Version:       5.7.1
+Release:       5
 License:       BSD-like
 Group:         Networking/Daemons
 Source0:       http://downloads.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
-# Source0-md5: 79e2b9cac947567a01ae2cc67ad8fe53
+# Source0-md5: c95d08fd5d93df0c11a2e1bdf0e01e0b
 Source1:       %{name}d.init
 Source2:       %{name}d.conf
 Source3:       %{name}d.sysconfig
@@ -57,16 +55,21 @@ Patch11:    %{name}-defaultconfig.patch
 Patch12:       %{name}-use-rpm-hrmib.patch
 Patch13:       %{name}-TCP_STATS_CACHE_TIMEOUT.patch
 Patch14:       %{name}-libnl.patch
+Patch15:       %{name}-libpci-init.patch
+Patch16:       %{name}-recognize-reiserfs.patch
+Patch17:       net-snmp-logging.patch
 URL:           http://www.net-snmp.org/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake
 BuildRequires: elfutils-devel
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-BuildRequires: libnl-devel >= 1:3.0
+BuildRequires: libnl-devel >= 1:3.2
+BuildRequires: libssh2-devel
 BuildRequires: libtool >= 1.4
 BuildRequires: libwrap-devel
 %{?with_lm_sensors:BuildRequires:      lm_sensors-devel >= 3.0.1}
 BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: pciutils-devel
 %{?with_autodeps:BuildRequires:        perl-Term-ReadKey}
 BuildRequires: perl-devel >= 1:5.8.0
 %if %{with python}
@@ -84,6 +87,7 @@ Requires(post,preun): /sbin/chkconfig
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /usr/bin/setsid
 Requires:      mibs-%{name} = %{version}-%{release}
+Requires:      pciutils >= 3.1.7-5
 Requires:      rc-scripts >= 0.4.3.0
 Provides:      snmpd
 Obsoletes:     cmu-snmp
@@ -167,7 +171,7 @@ Group:              Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      elfutils-devel
 %{?with_kerberos5:Requires:    heimdal-devel}
-Requires:      libnl-devel >= 1:1.1
+Requires:      libnl-devel >= 1:3.2
 Requires:      libwrap-devel
 %{?with_lm_sensors:Requires:   lm_sensors-devel >= 3.0.1}
 Requires:      openssl-devel >= 0.9.7c
@@ -432,6 +436,9 @@ SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
 
 %build
 %{__libtoolize}
@@ -478,7 +485,7 @@ MIBS="$MIBS ucd-snmp/lmsensorsMib"
        --with-security-modules="%{?with_kerberos5:ksm }tsm" \
        --with-sys-contact="root@localhost" \
        --with-sys-location="Unknown" \
-       --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback Alias DTLSUDP TLSTCP" \
+       --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback Alias DTLSUDP TLSTCP SSH" \
        --with-persistent-directory="/var/lib/net-snmp" \
        --enable-ucd-snmp-compatibility \
        --enable-ipv6 \
@@ -497,8 +504,9 @@ cd perl
 # avoid rpaths generated by MakeMaker
 perl -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' */Makefile */*/Makefile
 
+bd=$(cd ..; pwd)
 %{__make} \
-       LDFLAGS="%{rpmldflags}"
+       LDFLAGS="%{rpmldflags} -L$bd/snmplib/.libs/ -L$bd/agent/.libs/"
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -508,18 +516,18 @@ install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,snmp},/var/log,/var/lib/n
        mibdir=%{_datadir}/mibs \
        DESTDIR=$RPM_BUILD_ROOT
 
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
 :> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.local.conf
 :> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmp.conf
 :> $RPM_BUILD_ROOT%{logfile}
 
 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmpd
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
-cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/snmpd
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/snmpd
 
 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmptrapd
-cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmptrapd.conf
-cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
+cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmptrapd.conf
+cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
 
 install -d $RPM_BUILD_ROOT/etc/init
 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/snmpd.conf
@@ -535,8 +543,8 @@ cd ..
 # IP-Filter (non-Linux)
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/ipf-mod.pl
 
-rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle/Makefile.subs.pl
+rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Bundle/NetSNMP/.packlist
 
 %if %{with static_libs}
@@ -599,9 +607,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README local
-%doc ChangeLog EXAMPLE.conf.def EXAMPLE.conf
-%doc FAQ NEWS PORTING README.snmpv3 TODO AGENT.txt
+%doc AGENT.txt CHANGES COPYING ChangeLog EXAMPLE.conf{,.def} FAQ NEWS README{,.agent-mibs,.agentx,.snmpv3,.sql,.thread} TODO local
 
 %attr(754,root,root) /etc/rc.d/init.d/snmpd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmpd
@@ -612,10 +618,10 @@ fi
 
 %attr(755,root,root) %{_sbindir}/snmpd
 %attr(755,root,root) %{_bindir}/net-snmp-create-v3-user
-
+%attr(755,root,root) %{_bindir}/sshtosnmp
 %dir %{_libdir}/snmp
 %dir %{_libdir}/snmp/dlmod
-
+%attr(755,root,root) %{_datadir}/snmp/snmp_perl.pl
 %{_mandir}/man1/net-snmp-create-v3-user.1*
 %{_mandir}/man5/snmpd.conf.5*
 %{_mandir}/man5/snmpd.examples.5*
@@ -629,8 +635,6 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
-%dir %{_sysconfdir}/snmp
-%dir %{_datadir}/snmp
 %attr(755,root,root) %{_libdir}/libnetsnmp.so.*.*.*
 %attr(755,root,root) %{_libdir}/libnetsnmpagent.so.*.*.*
 %attr(755,root,root) %{_libdir}/libnetsnmphelpers.so.*.*.*
@@ -641,6 +645,8 @@ fi
 %attr(755,root,root) %ghost %{_libdir}/libnetsnmphelpers.so.%{so_version}
 %attr(755,root,root) %ghost %{_libdir}/libnetsnmpmibs.so.%{so_version}
 %attr(755,root,root) %ghost %{_libdir}/libnetsnmptrapd.so.%{so_version}
+%dir %{_sysconfdir}/snmp
+%dir %{_datadir}/snmp
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.044463 seconds and 4 git commands to generate.